Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I downloaded vmware player 4.04 and run into the problem of virtual network device fail.

After googling a bit, I found How do I install VMware Player 4.0.3? and applied as this answer suggest, which is the following:

1) I downloaded the tarball http://weltall.heliohost.org/wordpress/wp-content/uploads/2012/01/vmware802fixlinux320.tar.gz

2) Change the plreqver=4.04

3) and run it. Everything looks working until I try to run vmware player again.

Now, it failed at the step "Virtual Machine Monitor" which was OK before I applied the patch. I guess the patch skerewed the whole VMware kernel modules.

Any help?

share|improve this question
add comment

1 Answer

up vote 1 down vote accepted

Open a terminal, navigate to directory where the patch is downloaded & unzipped.

Execute following

sed -i -e 's/8.0.2/8.0.4/g' patch-modules_3.2.0.sh. Re run the patch.

If you get a patch: command not found error, please install patch using

sudo apt-get install patch and rerun the patch script.

let us know how it went.

Related Question:

Unable To Install VMware WorkStation 8 on ubuntu 12.04

Is VMware 8 compatible with Ubuntu 12.04?

share|improve this answer
    
Thanks a lot! It seems working but after some moment, it dies with the following messages –  jaeyong Aug 9 '12 at 12:36
    
make[2]: *** [/tmp/vmware-root/modules/vmnet-only/netif.o] Error 1 make[1]: *** [_module_/tmp/vmware-root/modules/vmnet-only] Error 2 make[1]: Leaving directory /usr/src/linux-headers-3.2.0-23-generic-pae' make: *** [vmnet.ko] Error 2 make: Leaving directory /tmp/vmware-root/modules/vmnet-only' Unable to install vmnet –  jaeyong Aug 9 '12 at 12:37
    
The lines above looks very messy, How can I align them with lines in comments? –  jaeyong Aug 9 '12 at 12:37
    
you need to edit the question. I would suggest to remove the vmplayer completely and start a fresh install and patch –  Web-E Aug 9 '12 at 14:18
    
The patch should be used after using sed from my answer and changing plreqver version. I just installed it two days age. :) –  Web-E Aug 9 '12 at 14:20
show 1 more comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.