Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I have a strange problem on my 12.04 LTS machine: Sound works OK in wine (using spotify for instance), but none of the native linux apps are able to produce any sound. I tested rythmbox and VLC player, and they both show the same behaviour; they seem to play ok (progress bar moving etc) but no sound can be heard anywhere.

share|improve this question
add comment

2 Answers

That line worked for me, it fixed my Minecraft sound problem without resetting anything.

options snd-hda-intel model=generic

I put it at the end of

/etc/modprobe.d/alsa-base.conf
share|improve this answer
add comment

First, check in "Sound Settings" that correct outputs are selected, sound cards are properly configured, and that applications playing sound are listed in the "Applications" tab. If you think everything there is correct, install PulseAudio Volume Control.

Check that the correct device is selected as "Fallback" (in the "Output devices" tab), and then that applications currently playing sound are playing it on the correct sound card (Note: If something has HDMI output, it's very likely to show up as a sound card). Finally, check if the applications themselves are not muted in PulseAudio Volume Control.

share|improve this answer
    
I googled around a bit and found a suggestion to add the line: options snd-hda-intel model=generic last in my /etc/modprobe.d/alsa-base.conf file - and that seemed to do the trick; now the native linux apps play sounds ok (rythmbox + ubuntu system sounds at least). But, now Wine has gone silent instead. Spotify (in wine), that used to work ok before, has now stopped working. –  David K Aug 9 '12 at 7:50
    
What sound card(s) do you have? Output of aplay -l would be nice. –  FLamparski Aug 9 '12 at 7:59
    
aplay -l **** List of PLAYBACK Hardware Devices **** card 0: Intel [HDA Intel], device 0: HDA Generic [HDA Generic] Subdevices: 0/1 Subdevice #0: subdevice #0 –  David K Aug 9 '12 at 8:02
    
Try that but without options snd-hda-intel model=generic. Also, you might want to try this: help.ubuntu.com/community/SoundTroubleshootingProcedure –  FLamparski Aug 9 '12 at 8:13
    
Without options snd-hda-intel model=generic: aplay -l: **** List of PLAYBACK Hardware Devices **** card 0: Intel [HDA Intel], device 0: ALC262 Analog [ALC262 Analog] Subdevices: 0/1 Subdevice #0: subdevice #0 –  David K Aug 9 '12 at 8:23
show 2 more comments

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.