Ask Ubuntu is a question and answer site for Ubuntu users and developers. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

Still unsolved bug here and bug -report here, bug in 12.04 and apparently in many other versions. How can I create an bootable USB -stick with Ubuntu?

share|improve this question
ok I tried these methods: 1. I installed it in 12.04 because if I use 12.10 I would face some proeblems - did not work 2. I used Ubuntu 12.10.ios to see if I have the same error- worked no errors 3. changing usb - did not try 4. Using unitbootin - trying now 5. md5sum was -Correct – Suhaib Nov 11 '12 at 21:41
I tried no 3. and the same thing. Not working tried no. 4 worked but I had some problems when I go through the installation process. – Suhaib Nov 11 '12 at 22:48

You could try using UNetbootin, the Ubuntu package is called unetbootin.

share|improve this answer
Not working for Windows XP – kode Aug 26 '14 at 19:11
Could you be more specific, please? – bseibold Aug 27 '14 at 6:56

I have no idea what is the problem with the GUI -wrapper but this should work in Ubuntu, it works in Debian.

Check up the sdNUMBER and then as a root overwrite the stick, be sure that you overwrite the right stick!

$ dmesg|grep sd|less
# cat debian.iso > /dev/sdX
# sync

More here.

Example: notice like sdb, not like sdb1

    $ sudo su
    # root@xyz:/home/xyz# cat /home/xyz/Documents/Distros/debian-6.0.5-i386-netinst.iso >/dev/sdb
share|improve this answer
...this worked fine, the iso -file comes with the bootloader -- fed up to Ubuntu's bugs so switched to Debian. – hhh Aug 10 '12 at 5:37

For any Linux , Make Boot able USB drive with Unetbootin. Provide .iso image path and click write. ( Don't need to select even Linux and versions).

share|improve this answer

This worked in my case:

sudo dd if=ubuntu-14.04.2-desktop-i386.iso of=/dev/sdb
share|improve this answer
If you would use an Ubuntu ISO file in your command,your answer would be on topic. As it was, not so much. Just my 2 cents - corrected. – Elder Geek Jul 2 '15 at 2:05
Sorry, it was debian originally. I think I copied the wrong filename. – Nandakumar Jul 3 '15 at 12:15

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.