Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I cannot stop channel hopping on latest ubuntu, on aircrack website it sais that newotk managers or similar programs cause this...when launching airmon-ng it warns me that processes like dhcpi, network-manager can cause problems.

I tried to kill these processes with sudo kill -9 pid but the processes are immediately restarted.

I am using the ath9k driver.

share|improve this question
    
It does somewhat depend on the driver, but stopping all services noted in airmon-ng output should help. –  hbdgaf Aug 8 '12 at 22:06
    
Does this work if you roll back to an earlier kernel? –  belacqua Aug 9 '12 at 0:27

3 Answers 3

You will need to stop their services, not simply kill the process. Here's what you can do:

sudo service avahi-daemon stop
  • This stops the avahi-daemon.
sudo service network-manager stop
  • This stops Network Manager.
sudo wpa_cli -i wlan0 terminate
  • This should kill wpa_supplicant on your wlan0 interface.
sudo kill -9 dhclient_pid
  • Replace dhclient_pid with the pid of dhclient.

I suggest not executing all of these at once, but instead execute one and then check the channel hopping.

share|improve this answer

This should stop the network-manager, but I'm not sure if it will solve the issue:

sudo service network-manager stop

From: http://ubuntuforums.org/showthread.php?t=1481660

share|improve this answer
    
Should I installl compat-wireless ? –  alal Aug 8 '12 at 22:08
    
Kling the process didn't help...what should i do ? –  alal Aug 8 '12 at 22:28
    
Sorry, I never found a good solution to the channel hopping problem. –  Jeff Aug 8 '12 at 22:39

Before setting your interface into monitor mode and trying to use any of the aircrack's wireless monitor and injection tools (ie: airodump-ng, aireplay-ng), always stop all network related services.

This is the command I use to stop all networking services and starting airmon:

sudo service avahi-daemon stop ; sudo service network-manager stop ; sudo wpa_cli -i wlan0 terminate ; sudo airmon-ng start wlan0

This is the command I use to stop airmon and starting all networking services back on:

sudo airmon-ng stop wlan0mon; sudo service network-manager start; sudo service avahi-daemon start

(Note that "wlan0mon" is the new notation for interfaces in monitor mode, starting with version 1.2-RC1. For previous versions, use "mon0")

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.