Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I'm trying to format an external hard drive (Iomega 1TB) using Disk Utility but when but when I select Format Volume or Format Drive, it shows me the error:

Error creating file system: helper exited with exit code 1: Error calling fsync(2) on /dev/sdb1: Input/output error

I tried with Gparted too, but it doesn't find the drive.

Can anyone give me some hint? Thanks in advance.

P.S: I tried in Windows, but it doesn't work too. It says that I don't have write permission.

share|improve this question
    
Are you able to access the files in the drive? –  To Do Aug 8 '12 at 20:18
    
You may also want to try another USB port, if you haven't already. Faulty USB ports could cause this issue too. –  reverendj1 Aug 8 '12 at 20:27
add comment

1 Answer 1

up vote 1 down vote accepted

An input/output error is often a hardware error like a bad sector on the disk. Check the output of the dmesg command to see if your hard drive was reporting any disk errors. Inside Disk Utility, you can also look at the "SMART Status" and "SMART Data" options to see if any hardware problems are being reported by the hard drive itself.

It is also possible that the error is due to USB problems or some similar communication issue. Again, the output of dmesg may help you track that down.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.