Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I am having trouble getting my Epson Perfection V100 Photo scanner to run under Ubuntu 12.04.

After I changed my Desktop it seems that I can't install the Epson Scanner.

Does anybody has an idea how I can fix this problem?

share|improve this question
    
Welcome, have you check if you scanner is support on Ubuntu. Check here wiki.ubuntu.com/HardwareSupportComponentsScannersEpson –  Stephen Myall Aug 8 '12 at 20:55
    
I seriously doubt that list is complete. Could you run lsusb in a Terminal window and post the output here? –  Cumulus007 Aug 8 '12 at 21:02
add comment

4 Answers 4

I have an Epson V350 Perfection Scanner running on Ubuntu 12.04.1 LTS. I could not get it to work with the latest drivers, but the following worked:

dpkg -i iscan-data_1.8.0-0_all.deb

dpkg -i iscan_2.26.2-1.ltdl7_i386.deb

dpkg -i iscan-plugin-gt-f700_2.1.0-3_i386.deb

These were files I downloaded and saved from a couple of years ago, where iscan is at version 2.26.2-1. The earliest version from avasys (http://avasys.jp/eng/linux_driver/download/) is 2.28 and this did not work for me. Version 2.29 does not install - it complains about missing dependencies libjpeg62 and libltdl3. When I tried to install these, I was told there was "no known source" for libltdl3. Version 2.29 is available from Epson here: http://download.ebz.epson.net/dsc/du/02/DriverDownloadInfo.do?LG2=EN&CN2=&DSCMI=20233&DSCCHK=e8c8d6c7f9da68399277d5eddbf8121aecda09d5

share|improve this answer
add comment

There are .deb packages of the drivers for the Epson Perfection V100 scanner here, which were referenced in an old support ticket at Launchpad. Previously you had to use alien to convert the rpms to debs, but now the deb packages are available.

You must install these packages from the first link above in the correct order, by referring to this guide and this more detailed pdf here. There are 32 bit and 64 bit drivers available, so you must choose the right ones for your architecture- this is the 32 bit version given below, but the 64 bit ones will labelled similarly, but with amd64 instead of i386.

Install in the following order:

1) data package: iscan-data_1.13.0-1_all.deb

2) core packages: (from the Ubuntu 8.10 or later section)iscan_2.28.1-3.ltdl7_i386.deb and iscan-plugin-gt-s600_2.1.2-1_i386.deb

This is probably your best hope, as your scanner model isn't properly supported in Sane or Xsane unfortunately.

share|improve this answer
add comment

The current downloads work on ubuntu 12.04 when also installing

http://packages.ubuntu.com/en/hardy/amd64/libltdl3/download

and adding to

/etc/udev/libsane-extras.rules

the lines:

# EPSON Perfection V100
SYSFS{idVendor}=="04b8", SYSFS{idProduct}=="012d", MODE="0664", GROUP="scanner", ENV{libsane_matched}="yes"
share|improve this answer
add comment

There are versions of iscan-data and iscan at https://github.com/hean01/iscan and https://github.com/hean01/iscan. I haven't tried these yet, but am putting this here in case someone finds it useful. If I wind up using them I will update.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.