Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I can't connect to the Internet in 11.10.

I tried switching my wifi card to another USB slot but nothing changed. Is it possible that the card is able to connect while not being able to receive packages?

$ ifconfig

eth0      Link encap:Ethernet  HWaddr 40:61:86:35:11:b0  
          UP BROADCAST MULTICAST  MTU:1500  Metric:1
          RX packets:0 errors:0 dropped:0 overruns:0 frame:0
          TX packets:0 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000 
          RX bytes:0 (0.0 B)  TX bytes:0 (0.0 B)
          Interrupt:43 Base address:0x6000 

lo        Link encap:Local Loopback  
          inet addr:127.0.0.1  Mask:255.0.0.0
          inet6 addr: ::1/128 Scope:Host
          UP LOOPBACK RUNNING  MTU:16436  Metric:1
          RX packets:0 errors:0 dropped:0 overruns:0 frame:0
          TX packets:0 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:0 
          RX bytes:0 (0.0 B)  TX bytes:0 (0.0 B)

wlan0     Link encap:Ethernet  HWaddr 74:ea:3a:8c:d5:5c  
          inet addr:192.168.2.5  Bcast:192.168.2.255  Mask:255.255.255.0
          inet6 addr: fe80::76ea:3aff:fe8c:d55c/64 Scope:Link
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
          RX packets:12 errors:0 dropped:0 overruns:0 frame:0
          TX packets:102 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000 
          RX bytes:1209 (1.2 KB)  TX bytes:15329 (15.3 KB)
share|improve this question
1  
Yes it's possible to be connected to your network and have no internet connection. What /sbin/ifconfig and ping www.google.com gives? –  LnxSlck Aug 8 '12 at 15:09
    
I cant ping google -unkown host –  Sandro Livaja Aug 8 '12 at 16:03
    
And the result of /sbin/ifconfig ? –  LnxSlck Aug 8 '12 at 16:10
    
Ill try ro edit post .seems that i cant post large texts in comments over my phone –  Sandro Livaja Aug 8 '12 at 16:24
1  
Try adding the ip of your router to the /etc/resolv.conf file: nameserver 127.0.0.1 –  LnxSlck Aug 8 '12 at 17:11

2 Answers 2

First you need to know what ip is your router, if you have dhcp it should be something like this:

192.168.2.5 - Your IP

192.168.2.1 - Your router ip address (i'm just guessing)

Then edit the resolv.conf file:

sudo vi /etc/resolv.conf

Add the line

nameserver 192.168.2.1

Save and exit

Try:

ping -c 3 www.google.com

---- Another solution

Edit the resolv.conf file:

sudo vi /etc/resolv.conf

Add the lines

nameserver 8.8.8.8

nameserver 8.8.4.4

Try

ping www.google.com

If that doesn't work, reboot your pc

share|improve this answer
    
i cant ping google still,what a mess.i would update my pc via my ethernet in living room if there was no other solution –  Sandro Livaja Aug 8 '12 at 17:28
    
Do you know your router ip? Can you ping it? –  LnxSlck Aug 8 '12 at 17:50
    
Yes i can ping it and the ip is 192.168.2.1 –  Sandro Livaja Aug 8 '12 at 17:53
    
Yes i know my router ip and i xan ping it –  Sandro Livaja Aug 8 '12 at 18:01
    
I believe you have a dns problem, i updated my answer with another solution, please try it –  LnxSlck Aug 8 '12 at 18:04

You do in fact seem to have a DNS problem, easy way to check is, right click onthe network manager applet, edit connections, go to wireless, wlan0, IPv4 Settings and add 8.8.8.8 to additional DNS servers

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.