Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

This is a bug I run into every couple of days, with IntelliJ IDEA's "Go to Class..." (or "Go to File...") dialog.

Usually it closes normally (when a class is selected or Esc pressed), but sometimes the popup is left behind, in the middle of the screen, on top of everything else. Even when I quit (or kill) IDEA completely, it stays. Example of what it looks like:

enter image description here

Only way I've found to get rid of it is logging out completely and then back in (i.e. restart X / GNOME). But having to do that is very annoying, as it can take 10 minutes or whatever to save (and re-setup afterwards) everything I have open.

Is there any other way to get rid of the buggy popup dialog, while remaining logged in? (Such as restarting some GNOME or X service / process.)


Using Ubuntu 11.04 and GNOME (not Unity).

IntelliJ IDEA ultimate edition 10.5, running on Sun's JDK 1.6.0_26 (i.e. sun-java6-jdk version 6.26-2natty1)

Some info about the graphics driver:

$ jockey-text -l
xorg:fglrx - ATI/AMD proprietary FGLRX graphics driver (Proprietary, Disabled, Not in use)

And:

$ sudo lshw -c video
  *-display               
       description: VGA compatible controller
       product: RV730 PRO [Radeon HD 4650]
       vendor: ATI Technologies Inc
       physical id: 0
       bus info: pci@0000:01:00.0
       version: 00
       width: 64 bits
       clock: 33MHz
       capabilities: pm pciexpress msi vga_controller bus_master cap_list rom
       configuration: driver=radeon latency=0
       resources: irq:47 memory:e0000000-efffffff memory:f0100000-f010ffff ioport:1100(size=256) memory:f0120000-f013ffff
share|improve this question
add comment

2 Answers

I asked on Twitter, and one of IntelliJ IDEA developers (Denis Zhdanov) replied:

I've encountered it under my ubuntu as well. Looks like a native problem because it persisted even after killing all java processes

I switched to java7 and Xrender pipeline eventually and don't observe the problem so far

I'm now trying if this helps, and will report back later. To recap, this is what I did:

  1. Switched to running IDEA on JRE 7. (If unsure of Java version used, check the Help -> About dialog.)
  2. Set the property -Dsun.java2d.xrender=true. As Denis points out, the best way is to edit the file <idea_home>/bin/idea.properties and add sun.java2d.xrender=true on a new line.
share|improve this answer
1  
It's recommended to configure IJ properties via $IJ_HOME/bin/idea.properties file, i.e. just add the following line to it: sun.java2d.xrender=True –  denis.zhdanov Aug 23 '12 at 13:26
    
@denis: yeah, that's much cleaner, thanks! –  Jonik Aug 23 '12 at 13:29
    
Any idea if this is specific to 11.04 or can we generalize the tags on this question? –  Jorge Castro Aug 24 '12 at 2:40
    
Can't be sure about that. Just can say that I observed the problem only under 11.x and 12.x IJ versions. –  denis.zhdanov Aug 24 '12 at 5:34
    
@denis: Also affects IJ 10.x which I'm using. (I don't know either if this is Ubuntu 11.04 specific or not.) –  Jonik Aug 24 '12 at 20:40
show 1 more comment

Run xkill from the "Run command" window, which can be invoked using alt+f2. Next, click the popup and its process should be killed.

Now, of course, this appears to be a bug in the application. I recommend you report it to the developers.

share|improve this answer
    
No, xkill doesn't work - the click "goes through" to the GNOME desktop (which seems to get reloaded somehow). Sorry, forgot to mention that I've tried this. –  Jonik Aug 8 '12 at 13:41
    
(The bug could be in many places: in the application, in Java's Swing (in which it is implemented afaik), the graphics card driver, etc. Quite possibly this only happens with some unfortunate combination of hardware and software.) But yeah, might be worth having a look at IDEA forums/bug tracker - maybe they know a workaround. –  Jonik Aug 8 '12 at 13:44
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.