Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I am running 12.04 with an HD7970. I installed fglrx from AMD and it worked okay. Then Ubuntu prompted me to install updates (from software-center). After doing this, the PC only boots to a black screen called Chips tty1.

If I go to the recovery mode, all the options give me a blinking cursor (after a confirmation dialog), but when I press Ctrl+Alt+Del then they react (repair, gfx safe) and shortly after it reboots.

If I choose the normal boot, I get an orange

"Mountall: Plymouth disconnected".

share|improve this question

1 Answer 1

Follow these commands:

sudo apt-get update  
sudo apt-get -d install --reinstall gdm  
sudo apt-get remove --purge gdm  

(I ran this command above, but was told by the system to use # sudo apt-get autoremove instead, after the #sudo apt-get remove --purge gdm command.)

sudo apt-get install gdm

select GDM when prompted

sudo reboot

That fixed it for me :)

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.