Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I have an music app that reports the following when I run it

gm3u: error while loading shared libraries: libgnomeui.so.32: cannot open shared object file: No such file or directory

I can't seem to find what package will install this library.

share|improve this question
    
Look at this: ubuntuforums.org/showthread.php?t=474778 –  Uri Herrera Aug 8 '12 at 8:00
    
That solution - sudo apt-get install libgnomeui32 - no longer works as the package is not available. –  Jazz Aug 8 '12 at 8:44
add comment

1 Answer 1

up vote 1 down vote accepted

That looks like a very old package -- libgnomeui.so.32 refers to the old GNOME 1 libraries. It's no longer available in Ubuntu.

Unfortunately, I tried compiling the gm3u source code but even that wants the GNOME1 development libraries and fails...

share|improve this answer
    
Is there no backward compatibility for gnome apps? –  Jazz Aug 8 '12 at 8:45
    
If you can recompile from source, yes, but in this case the source is poorly written... Unfortunately, it's like trying to run a Windows 3.1 application on Windows 7... –  izx Aug 8 '12 at 8:47
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.