Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I could open video files but then I installed ffmpeg to install opencv and now it does not open video files. I tried vlc and ubuntu's Movie Player to open .mkv, .avi, and .mp4 but none of them opened. When I try opening them from the command line with vlc I get this:

[0x2145070] mkv demux error: cannot load some cues/chapters/tags etc. (broken seekhead or file) [0x2145070] mkv demux error: cannot load some cues/chapters/tags etc. (broken seekhead or file) Segmentation fault

I have ubuntu 11.10 64bit. I used this guide to install ffmpeg. When configuring x264 and ffmpeg I enabled shared and fPIC.

Can anyone help me?

share|improve this question
    
This might be memory related. Try to do a memory check. –  Mitch Aug 8 '12 at 8:21
    
Happy you've solved the problem. Mind explaining a bit how you eventually solved the problem? I have a few different solutions in my answer. –  Tomas Apr 16 '13 at 3:36
add comment

1 Answer

up vote 1 down vote accepted

That is very odd. VLC has the codecs built-in, so it should not matter what you do with ffmpeg. Unless installing ffmpeg somehow messed up a library VLC was depending on...

The error you get sounds to me like there is something wrong with the file you're trying to open. Bit too basic maybe, but have you tried opening another video file, including one with a different file type (e.g. avi)?

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.