Ask Ubuntu is a question and answer site for Ubuntu users and developers. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I'm running Ubuntu Lucid which contains the Gnome 2.30. The thing is that, I'm really interested on using empathy 2.32, since it fixes a lot of bugs. However I don't want to upgrade the entire system but I really want the new version of empathy :3. I tried using ppa or other methods but no luck. Any idea?

share|improve this question
have you tried compiling it from source? – crodjer Dec 22 '10 at 5:45
up vote 4 down vote accepted

I just tried to build empathy from Maverick for Lucid, but it's not possible due to unmet build dependencies. The easiest other solution that I can think of is just to install the Maverick package using apt, and making use of pinning to keep the impact on your system to the minimum. This will require you to upgrade GTK+ and some other system components, but it's not so bad and works just fine for me. YMMV though, I'm not responsible if you break your system.

Here's how I just did it.

Open up /etc/apt/sources.list, and add Maverick sources at the bottom:

deb maverick main restricted universe multiverse
deb-src maverick main restricted universe multiverse
deb maverick-updates main restricted universe multiverse
deb-src maverick-updates main restricted universe multiverse
deb maverick-security main restricted universe multiverse
deb-src maverick-security main restricted universe multiverse

(or use your preferred mirror). Don't do anything with apt yet. Next we'll open up the apt pinning file /etc/apt/preferences and tell apt not to install packages from Maverick (see man apt_preferences for more):

Package: *
Pin: release a=maverick
Pin-Priority: 1

Now run aptitude update to get the package indexes from these new sources you just added. Next call aptitude install empathy/maverick-updates to instruct aptitude to explicitly pull the package from Maverick instead of Lucid (the default). aptitude will tell you it wants to upgrade to a number of packages from Maverick:

Upgrade the following packages:
gconf2 [2.28.1-0ubuntu1 (lucid, now) -> 2.31.91-0ubuntu3.1 (maverick-updates)]
gnome-icon-theme [2.28.0-1ubuntu1 (lucid, now) -> 2.31.0-0ubuntu1 (maverick)]
libdbus-glib-1-2 [0.84-1 (lucid, now) -> 0.88-2 (maverick)]
libdbusmenu-glib1 [0.2.9-0ubuntu3.1 (lucid-updates, now) -> 0.3.16-0ubuntu1 (maverick)]
libgail18 [2.20.1-0ubuntu2 (lucid-updates, now) -> 2.22.0-0ubuntu1 (maverick)]
libglib2.0-0 [2.24.1-0ubuntu1 (lucid-updates, now) -> 2.26.0-0ubuntu1 (maverick)]
libgtk2.0-0 [2.20.1-0ubuntu2 (lucid-updates, now) -> 2.22.0-0ubuntu1 (maverick)]
libgtk2.0-bin [2.20.1-0ubuntu2 (lucid-updates, now) -> 2.22.0-0ubuntu1 (maverick)]
libnotify1 [0.4.5-1ubuntu4 (lucid-updates, now) -> 0.5.0-2ubuntu1 (maverick)]
librsvg2-2 [2.26.3-0ubuntu1 (lucid-updates, now) -> 2.32.0-0ubuntu1 (maverick)]
librsvg2-common [2.26.3-0ubuntu1 (lucid-updates, now) -> 2.32.0-0ubuntu1 (maverick)]
libsqlite3-0 [3.6.22-1 (lucid, now) -> 3.7.2-1 (maverick)]
libtelepathy-glib0 [0.10.1-1ubuntu2 (lucid, now) -> 0.12.0-0ubuntu1 (maverick)]
nautilus-sendto-empathy [2.30.3-0ubuntu1 (lucid-updates, now) -> 2.32.1-0ubuntu1 (maverick-updates)]

Agree to this if you don't think it's too bad (like I said, worked for me), and you'll end up with a newer Empathy.

Good luck!

share|improve this answer
Your solution may work, but it still makes major changes/updates to key components of the system (libdus, etc) which as Marcos already said, is not acceptable. – Pavlos G. Dec 23 '10 at 12:42
I said that. If a package depends on newer libraries then there is now way around it, you have to upgrade to them. – Iain Lane Dec 23 '10 at 12:52
I'll try this when I get home. It seems the only viable/possible solution. Even if it's doesn't work your research is valid. Bounty :) – Marcos Roriz Junior Dec 24 '10 at 4:20

you could go to launchpad and request that the app be backported to lucid

share|improve this answer

At the bottom of the package's page you can find the download links for the latest version (AMD64 or x86):

The only other dependency you might have to meet is that of the empathy-common package.
Besides that, all other packages seems to need gnome versions >= 2.30.2, so you could give it a try.

share|improve this answer
Unfortunately I get in a depedency hell, since libdbus* and other also need to be changed and they eventually touch key components of the system. – Marcos Roriz Junior Dec 14 '10 at 16:14
I couldn't verify that as i'm already using maverick. I guess it's not that easy then... :-( – Pavlos G. Dec 14 '10 at 16:32

You can use the method mentioned by Iain, but just do it in a chroot.

share|improve this answer

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.