Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I just bought a laptop from CyberPower PC company and opted out of spending $39 for them to install windows 8. I just booted Precise Pangolin from a flash drive and installed it on my computer. Everything works fine except for the wireless capabilities. I have looked at several of the posts on the forum and haven't been able to ascertain the solution to my problem. I know that the wireless network card is from Atheros and that's about it. When I tried the iwconfig command and this is what came up and this is what resulted:

$ sudo iwconfig
lo     no wireless extensions
eth0   no wireless extensions

I also tried installing the ath9k driver and the atl1c driver as shown in this post on the boards: Ethernet conection not working Atheros AR8152 OS 12.04

It seems that neither of the drivers have worked and I'm not sure exactly what to do. The above post is old and is using an one of the older versions of the compat...tar.bz2 file than the most current one on the website. I am very new to Ubuntu so I am rather lost at what I should be doing next. I have no idea why the post worked for the other users and not for myself or if I should be attacking this problem from an entirely different perspective.

Also, I'm not sure what model my Atheros card is or how that can be found. Any help is greatly appreciated.

share|improve this question
    
please add the output of 'lspci' –  Germar Aug 8 '12 at 3:36
add comment

3 Answers

http://ubuntuforums.org/showthread.php?t=2035902&page=3

I was given this link on reddit.com. It saved my life and now my wireless is working great. Thanks everyone who chipped in!

share|improve this answer
    
I looked for the thread tools at the top of the page to make this thread [solved], but I couldn't find them. I made this thread by giving my email, and did not make a formal account with ubuntuforums.com is there any way that I or a mod could close this thread and link it to the above web address? –  JON Aug 9 '12 at 4:22
add comment

Look in device manager and see if there is a bang next to the wireless network card if so then your computer sees it.

I'm not sure what model my Atheros card is or how that can be found.

Look in the BIOS and it will tell you what kind of card it is, also make sure its enabled in BIOS that may be your issue, if not then again go in BIOS to enable it. You might have to update the BIOS.

share|improve this answer
    
I checked System Settings > Network/ and only found menu options for "wired" and for "network proxy," nothing about wireless connections. What would the "bang" look like if I were to find it? I'll check the BIOS and report back in a jiffy. Thx –  JON Aug 8 '12 at 4:34
    
So I actually couldn't find the network card in BIOS. Maybe I'm just dumb but it wasn't there. I found the hard drive specs and other stuff, but nothing about wireless. How do I update the BIOS? –  JON Aug 8 '12 at 4:43
add comment

I had the same problem on a DELL machine after reinstallation of Ubuntu 12.04 LTS (precise). I did the following and after rebooting the pc, the wireless was there again! Note: You have to have to be connected to the internet (wired connection)!!

1. sudo apt-get remove --purge bcmwl-kernel-source
2. sudo apt-get install firmware-b43-installer
3. sudo apt-get install b43-fwcutter (though you do not need this step since the 'b43-fwcutter' package is a dependency for the 'firmware-b43-installer' package, so it automatically gets installed in step 2)
4.  sudo apt-get install firmware-b43legacy-installer  (if you are using the b43-legacy wireless)
5. sudo apt-get install bcmwl-kernel-source
6. sudo reboot 

I hope this will also work for you! Cheers, Peyman

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.