Ask Ubuntu is a question and answer site for Ubuntu users and developers. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I'm using 10.04 using VMWare Player. The virtual machine is very very slow and is hanging often. I have to force shutdown the system whenever it hangs. Mine is a Dell laptop with 4GB RAM i3 processor and 2.40GHz frequency.

I'm not sure if it is a problem with my processor. I could have comfortably used Ubuntu even if it is a bit slow. But the terminal and everything hangs. Let me know when someone face the same problem with a solution.

share|improve this question
What is the host system? I understand, that you reboot the host system, is this true? – user unknown Aug 8 '12 at 2:01
PS: why are you using VWWare Player? You can't use VirtualBox, or QEMU? – Ramchandra Apte Aug 8 '12 at 3:05
How much RAM do you have allocated to your virtual machine? Is there any significant disk activity when you're using it (i.e. HDD light flashing constantly etc.) Do you have some resource-intensive background processes running in the virtual machine (such has a mis-configured database server)? Can you run top in the terminal and see what process is using most of resources? – Sergey Aug 8 '12 at 3:06
@Sergey I ran the command grep MemTotal.. and it shows that the MemTotal is 1019080kB. When i run top command, it shows that 882476k used and 136604k free. There are 128 tasks and only 1 is running and 127 are sleeping. By HDD you mean the usage of Hard Disk Drive? I'm sorry but iam completely new to Linux and I really want to learn. Im using ubuntu 10.4 - thanks – user1455116 Aug 8 '12 at 3:23
@user1455116: I suspected that the VM has too little RAM allocated to it (say, 256Mb or less) - in which case it would constantly swap, causing a lot of disk activity and slowing to a crawl. You would hear HDD making noices and LED blinking. This doesn't appear to be the case, 1Gb of RAM should be enough, although, if you can, you can try increasing the RAM to, say, 2Gb to see if it improves things. – Sergey Aug 8 '12 at 3:37
up vote -1 down vote accepted

The most popular bootleneck in every laptop and in many many desktop is the HDD. Probably your HDD is under stress and simply couldn't keep it up with all your I/O requests.

Your CPU is not an i7 but it should be at least a dual core with an high frequency and most likely your HDD is performing worse than your CPU.

If you have an external HDD try with this one.

share|improve this answer
So, the HDD is a bottleneck for running a terminal application, huh? Would upgrading to an SSD improve things? :) Surely the OP's machine is more than capable of handling a single VM running Ubuntu, the problems are almost certainly caused by mis-configuration of either the host machine or the guest. – Sergey Aug 8 '12 at 3:11
the fact that your run this application from the terminal doesn't mean that it is lightweight. the SSD are really fast, but they are not that cheap, an external USB HDD can be used as backup device but this is a slower solution due to both HDD ( they usually have a "low" rpm value ) and USB limitations. The choice is up to you, if you want something flexible go for an external HDD, if you want performance use an SSD, you can also use your actual HDD as an external HDD buying a new SSD for internal storage and an USB box to use the old HDD as external device. – user827992 Aug 9 '12 at 13:56
The OP stated that "the terminal and everything hangs", which I interpret as "running terminal emulator is slow", not as "running some resource-intensive IO-bound console application is slow", the OP never mentions any such applications. Performance of the slowest hard drive available would be more than enough to be able to start an xterm window without hanging. – Sergey Aug 10 '12 at 0:53
@Sergey just read the title ... – user827992 Aug 10 '12 at 0:55

I had the same problem and as people mentioned, the problem is RAM and HDD. Even if it says that a lot of RAM is free, it doesn't mean it's actually free - it still used by 'standby' processes. When VM needs memory, it starts swapping on HDD. You can use resource monitor (perfmon.exe /res) to see that. What I did:

  1. Increase physical memory, the more the merrier
  2. Increase VM memory allocation (in VM settings)
  3. Change HDD to SSD, makes the computer fly!
share|improve this answer

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.