Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

Question:

I recently installed Xen (paravirtualization) on my Ubuntu 12.04 machine.
Ubuntu 12.04 worked excellently before, but afterwards, the trouble started.

The laptop crashed every time I closed down the screen.

Unsurprisingly, that resulted in file-system corruption.
Though the real trouble did not start until fsck complained about corruption and "repaired" it (I tried to abort it right away, but to no avail, Ubuntu wouldn't let me continue until I ran that damn more-trouble-than-worth program...).

The system run fine after a second restart (on the first restart, after some time, the file system switched to read-only for whatever reason...)

I afterward installed dist-upgrade (250 MB), to try to mitigate any trouble caused by corruption.

I restarted, it still worked fine.

I compiled bind9, latest version, compiling takes 15+ minutes, so I went to eat, meanwhile the laptop went into standby...

When I came back and tried to wake it, the screen remained black. Closing and opening the screen didn't help. As usual on the Xen kernel. So I switched off power, and on reboot, got the error message I am still fighting with right now:

Intel UNDI, PXE-2.0 (build 083)
Copyright (C) 1997 - 2000 Intel Corporation

For Atheros PCIE Ethernet Controller v2.0.2.3(05/18/10)

Check cable connection!
PXE-M0F: Exiting Intel PXE ROM.
No bootable device -- insert boot disk and press any key

The funny thing is, PXE Netboot is not enabled in my BIOS, so I shouldn't see this message.
Also, the BIOS boot-sequence is 1. USB stick - 2. HardDrive - 3. CD/DVD - 4. Network

I tried booting via the Ubuntu Live CD on a USB stick, and with that, I could access the data on my HardDrive, everything seems to still be there.

I ran the boot-repair tool, as recommended here

https://help.ubuntu.com/community/Boot-Repair

But that didn't help.
I still get the same error message on boot.
The good news is, the data seems to still be there...

Here is my boot-repair paste:
http://paste.ubuntu.com/1134895/

And that's it.
Anybody knows what I can do, short of copying down the data and reinstalling ?

To me it seems like Xen is in some strange boot state from the stand-by, and now tries to boot of PXE, which of course doesn't work, since there is nothing - fortunately.

share|improve this question
add comment

closed as off-topic by RolandiXor Dec 18 '13 at 5:02

This question appears to be off-topic. The users who voted to close gave this specific reason:

  • "This describes a problem that can't be reproduced that seemingly went away on its own or was only relevant to a very specific period of time. It's off-topic as it's unlikely to help future readers." – RolandiXor
If this question can be reworded to fit the rules in the help center, please edit the question.

1 Answer

up vote 1 down vote accepted

Oh man I get it working.

For the record, if anyone has the same problem:

If you get this message (and your BIOS settings are OK):

  1. Switch off your laptop for more than 30 seconds.

  2. Start, and wait until you get to the error screen

  3. press CTRL + ALT + DEL

  4. Wait as it reboots, until you the the same error screen again

  5. Press the power button and wait until it switches off.

  6. Wait no longer than 5 seconds, and then press the power button

  7. It boots to grub selection ! In grub, select "recovery" (because normal startup won't work)

  8. Select "regenerate grub" or whatever it is called.

  9. afterwards, select boot

Edit:
Diagnosis: HD defect

share|improve this answer
add comment

Not the answer you're looking for? Browse other questions tagged or ask your own question.