Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I have a problem, when I want to login in nodes. My nodes are created via MAAS dashboard, where I'm adding nodes. But when installation completes I'm asking to login and password to get into the node. But they wasn't shown or I missing something. I need to login to nodes to check clock and solve other issues.

share|improve this question
add comment

2 Answers

up vote 3 down vote accepted

I assume you're trying to log in through SSH. Did you also register your SSH key(s) with MAAS? You need to do that, before you allocate the node to yourself (in the UI that's the Start Node button).

I believe the default username is ubuntu — so if you've gone through these steps, you should be able to ssh into the node with username ubuntu and no password.

share|improve this answer
1  
Yes you are right I understood it before I read your post. But the main problem I had never register ssh keys. I know it's simple task but I'm fresh with Linux. So if you give me more information about how to do that. If I would install nodes manually I think it would be easier to do. –  Nerijus Aug 21 '12 at 21:27
add comment

OK what I got is that you had successfully installed maas, successfully added the nodes and they are at Ready state.

Hence all you have to do is export your ssh key on maas controller ssh-keygen -t rsa -b 2048, press enter couple of times, open the key vi ~/.ssh/id_rsa.pub and copy the whole thing.

Then log in the maas gui, click on your username on the top right corner => preferences => add ssh key and past it.

Now go to all the nodes, start them, and boot them up if they didn't automatically.

Finally ssh node_IP_address from the maas controller.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.