Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

Im using ubuntu 10 and the firefox 10.0. When using the address bar to search, when i type long words like 'search this in google' the search defaults to google. But when i type in small words like 'search' the browser uses centurylink. Please let me know how to get rid of this and make google as default search engine.

share|improve this question

3 Answers 3

I found the answer that works for me: There is a spot on mine (mac OS) that says in faded letters "why am I here" or "why do I see this". I clicked it, and there was a place to click to disable Centruylink searches. Good luck!

share|improve this answer
    
Thanks! Worked for me on Firefox on Win8. –  goertzenator Nov 14 '13 at 15:45

From the Navigation Toolbar in search box select your favourite Search engine through this menu .

enter image description here

Or select the manage search Engines.. option to remove the Desired Search engine as from the image.

enter image description here

share|improve this answer
    
Hi I could not find any CenturuLink search in the options to remove –  user1455116 Aug 7 '12 at 21:43
    
@user1455116- To change the internet keyword search follow this link support.mozilla.org/en-US/kb/search-web-address-bar –  atenz Aug 8 '12 at 6:12

It is most likely that this is being done by centurylink (your isp) in response to failed DNS queries.

Without changing browsers you will be unable to fix this problem. However I do know that most versions of Chrome/Chromium will do some stuff to avoid this problem and, I believe, so does more recent versions of firefox.

share|improve this answer
    
on my windows system I'm using firefox 14.0.1 and still see the same problem. I do not want the search to redirect to CenturyLink –  user1455116 Aug 8 '12 at 1:09
    
Well in that case you can try using chromium/chrome which does some magic to avoid this problem entirely. Otherwise adding a space before or after the search term might avoid the problem. –  Alex L. Aug 8 '12 at 1:23

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.