Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I am currently running Ubuntu 12.04 LTS on a desktop that has a Intel i7 2600k with integrated Intel HD 3000 graphics and a GeForce GT430 1GB video card. I have 2 monitors (in a vertical orientation) connected through DVI to the GT430 card and one monitor (in horizontal orientation) connected to the DVI port on the motherboard. I can run the two vertical monitors without a problem, but I cannot get the third monitor to work, past constantly displaying a Ubuntu load screen. I have already set the intel integrated graphics to "always enabled" in BIOS, and have been playing around with the xorg.conf file for a while but cannot seem to get it to work properly.

Here is the current copy of my xorg.conf file:

# nvidia-settings: X configuration file generated by nvidia-settings
# nvidia-settings:  version 295.33  (buildd@allspice)  Fri Mar 30 15:25:24 UTC 2012

# nvidia-xconfig: X configuration file generated by nvidia-xconfig
# nvidia-xconfig:  version 295.49  (buildmeister@swio-display-x86-rhel47-07.nvidia.com)  Tue May  1 00:54:24 PDT 2012

Section "ServerLayout"
Identifier     "Layout0"
Screen      0  "Screen0" 0 0
InputDevice    "Keyboard0" "CoreKeyboard"
InputDevice    "Mouse0" "CorePointer"
Option         "Xinerama" "0"
EndSection

Section "Files"
EndSection

Section "InputDevice"

# generated from default
Identifier     "Mouse0"
Driver         "mouse"
Option         "Protocol" "auto"
Option         "Device" "/dev/psaux"
Option         "Emulate3Buttons" "no"
Option         "ZAxisMapping" "4 5"
EndSection

Section "InputDevice"

# generated from default
Identifier     "Keyboard0"
Driver         "kbd"
EndSection

Section "Monitor"

# HorizSync source: edid, VertRefresh source: edid
Identifier     "Monitor0"
VendorName     "Unknown"
ModelName      "DELL 2408WFP"
HorizSync       30.0 - 83.0
VertRefresh     56.0 - 76.0
Option         "DPMS"
EndSection

Section "Monitor"

# HorizSync source: edid, VertRefresh source: edid
Identifier     "Monitor1"
VendorName     "Unknown"
ModelName      "ViewSonic VA2231 Series"
HorizSync       24.0 - 82.0
VertRefresh     50.0 - 75.0
Option         "DPMS"
EndSection

Section "Device"
Identifier     "Device0"
Driver         "nvidia"
VendorName     "NVIDIA Corporation"
BoardName      "GeForce GT 430"
EndSection

Section "Device"
Identifier     "Device1"
Driver         "nvidia"
VendorName     "NVIDIA Corporation"
BoardName      "GeForce GT 430"
Option         "RandRRotation" "on"
BusID          "PCI:1:0:0"
Screen          1
EndSection

Section "Screen"

# Removed Option "TwinView" "0"
# Removed Option "metamodes" "DFP-0: nvidia-auto-select +0+0"
# Removed Option "metamodes" "DFP-0: nvidia-auto-select +0+0, DFP-1: nvidia-      auto-select +1920+0"
# Removed Option "MetaModes" "GPU-0.DFP-0: 1920x1200+0+0, GPU-0.DFP-1:    1920x1200+1920+0, GPU-1.DFP-0: 1920x1200+3840+0"
Identifier     "Screen0"
Device         "Device0"
Monitor        "Monitor0"
DefaultDepth    24
Option         "RandRRotation" "on"
Option         "BaseMosaic" "True"
Option         "TwinView" "1"
Option         "TwinViewXineramaInfoOrder" "DFP-0"
Option         "metamodes" "DFP-0: 1920x1200 +0+1200, DFP-1: 1920x1200 +0+0"
SubSection     "Display"
    Depth       24
EndSubSection
EndSection

Section "Screen"
Identifier     "Screen1"
Device         "Device1"
Monitor        "Monitor1"
DefaultDepth    24
Option         "TwinView" "0"
Option         "metamodes" "DFP-1: nvidia-auto-select +0+0"
SubSection     "Display"
    Depth       24
EndSubSection
EndSection

Does anyone know if what I am trying to do is possible given my setup? And if so how can I get it to work?

Any help would be appreciated and thank you in advance.

share|improve this question
    
Obvious item: your serverlayout section only references Screen0 and not Screen1, try adding a 2nd line Screen 1 "Screen1" RightOf "Screen0" (Note: you can fix the location later; the intention is to get X to use it first!). –  StarNamer Aug 7 '12 at 18:03
    
Thanks, added that, still basically in the same place though. Some text is now displaying on the third screen; stuff like Stopping System V runlevel compatibility –  Bullshark0 Aug 7 '12 at 18:48
add comment

Know someone who can answer? Share a link to this question via email, Google+, Twitter, or Facebook.

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Browse other questions tagged or ask your own question.