Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I'm having a problem with skipping audio on two different machines, both with up-to-date Ubuntu 12.04 Desktop installed (one 32 bit, the other 64)

It doesn't happen all the time (maybe once per song when it gets bad), and happens regardless of the program creating the audio (could be streaming through Grooveshark, or playing files with VLC, etc.)

Does anyone have any ideas as to why this is happening, or how I could fix it? I don't really even know where to start.

Thanks!

share|improve this question

2 Answers 2

up vote 0 down vote accepted

Jordan, I have been having this same issue for quite some time now. I followed the steps at this page and I haven't noticed any skipping when playing audio/video in VLC. Hopefully this solves the problem.

share|improve this answer
    
Sorry for the late response, but this worked! thanks! –  Jordan N Sep 26 '12 at 13:30

First I would check if it is a problem on PulseAudio or ALSA-level. Try playing some music in a program that outputs directly to ALSA (launched with pasuspender in Ubuntu). When I had a similar problem I used Mixxx.

If the skipping does not occur you can be pretty sure it is a PulseAudio problem.

share|improve this answer
    
Thanks for the response! I'll look into trying to output directly to ALSA. Let's say hypothetically it is a PulseAudio problem; do you know what next steps I should take to try and solve the issue? –  Jordan N Aug 7 '12 at 17:47
    
the only thing i could think of would be to increase buffer sizes significally and see if it helps. But in my case it was a problem with the usb connection to the audio interface... so, a lot of things can go wrong ;) –  Karl Frisk Aug 7 '12 at 22:26
    
When I tried to run rhythmbox, totem, and vlc using pasuspender I ended up with no sound at all. Any other suggestions? –  James McMahon Aug 21 '12 at 17:54
    
with vlc, did you change to alsa-output? (select ALSA audio output in Tools->Preferences->Audio) –  Karl Frisk Sep 16 '12 at 12:48

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.