Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I have two laptops running 12.04 and seem to have the same problem in both. When I open a dialog box, such as "File open", the Save button is off the side of my screen (see screen shot below). This problem seems to occur with all applications.

enter image description here

share|improve this question
add comment

1 Answer 1

up vote 2 down vote accepted
+50

It seems to me that I've seen this behaviour a couple of times:

  1. In one case the application was opening a window, the windows manager was centering it, and then the application was increasing its size. If that were the case here your windows would be displaced to the right--and they aren't.

  2. In another case I attached another monitor that had more resolution than my laptop, opened some apps, and then disconnected the larger monitor. The window manager kept on opening apps at the size they last used. I don't think logging off or rebooting helped.

What I did

I was able to resize the window from the upper left to the lower right, and then drag the window back up to the left, repeating until it didn't overfill the screen. When I closed and reopened it the window manager remembered the smaller size and I was all set.

Other Solutions

Other solutions referring to file dialog boxes are suggested in Why are my file selection dialogs so big? How do I make them smaller?. The answer from Amanda that solved a very similar problem for two individuals was this one.

gedit ~/.config/gtk-2.0/gtkfilechooser.ini

and remove the GeometryWidth and GeometryHeight lines.

Another from this answer by Timo Kluckat from the same question (this is where my dialog box settings are stored for gedit):

Install dconf-editor:

sudo apt-get install dconf-editor

Start it:

dconf-editor

Then select "org.gtk.setting.filechooser and change the window-size entry to (0,0) to reset to the default size.

share|improve this answer
    
For info, the solution that worked was to edit gtkfilechooser.ini –  csgillespie Aug 11 '12 at 18:35
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.