Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free.

I have a 1400x900 monitor and the maximum resolution the monitor can reach in Ubuntu is about 1024x800. However, in Windows 7 64-bit, the monitor can reach the maximum resolution possible.

Specs of my computer:

  • NVIDIA GeForce GT 240
  • 4 GB RAM
  • Intel Pentium Dual-Core
share|improve this question

closed as off topic by atenz, Mitch, Tachyons, Marco Ceppi Aug 17 '12 at 20:07

Questions on Ask Ubuntu are expected to relate to Ubuntu within the scope defined by the community. Consider editing the question or leaving comments for improvement if you believe the question can be reworded to fit within the scope. Read more about reopening questions here. If this question can be reworded to fit the rules in the help center, please edit the question.

Sorry ,It is basically a windows question and not suited for this site. –  atenz Aug 7 '12 at 11:07
@tijybba i think he tried to say that his windows7 shows 1400x900 but ubuntu does not. Whatever, #nico please provide more info about your machine. I think you have graphics card issue. Did you install additional graphics driver in ubuntu? Please provide your system specification. –  shantanu Aug 7 '12 at 11:19
Thanks for editing it and posting more info. @shantanu - i got it now :) –  atenz Aug 7 '12 at 11:20
@nico- have you tried changing the resolution in Ubuntu . –  atenz Aug 7 '12 at 11:22
Yes i have the highest resolution is 1024x800 in the setting menu –  Nico Aug 7 '12 at 11:26

1 Answer 1

I had the similar problem earlier but I was able to change the resolution using the XRANDR command from the command line interface. When I was happy with the setting I made a shell script to run at startup. This was my resolution used to change to what I set in the script.

Check out this post in Ubuntu Geek for changing the resolution via command line http://www.ubuntugeek.com/how-change-display-resolution-settings-using-xrandr.html

Once you manage to find the resolution that you are happy with (using the XRANDR) you can create a script (see shell scripting) and place it in one of your folders. You can then use Sudo chmod +x <filename> to make the file executable. After that go to start up applications and set this file to run at start up.

A shell script is pretty simple. All you'll need to do is create a file with the first line as #!/bin/sh or #!/bin/bash (depending on your profile) then the following lines would be what you typed in to the terminal to achieve the resolution you wanted. Each command will have to be placed on a new line. Save the file and make it executable as mentioned above.

share|improve this answer

Not the answer you're looking for? Browse other questions tagged or ask your own question.