Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I got this message in GParted when seeing information about a partition that is marked with the yellow warning icon in the partition list:

e2label: No such file or directory while trying to open /dev/sda6
Couldn't find valid filesystem superblock.

Couldn't find valid filesystem superblock.

dumpe2fs 1.42 (29-Nov-2011)
dumpe2fs: No such file or
directory while trying to open /
dev/sda6

Unable to read the contents of this file system!
Because of this some operations may be unavailable.

The cause might be a missing software package.
The following list of software packages is required for ext4
file system support: e2fsprogs v1.41+.

I've checked that e2fsprogs is already the newest version. This is the result of ls /dev/sda*:

/dev/sda  /dev/sda2  /dev/sda5  /dev/sda7

There's no /dev/sda6, but this is the result of sudo fdisk -l:

Disk /dev/sda: 120.0 GB, 120034123776 bytes
255 heads, 63 sectors/track, 14593 cylinders, total 234441648 sectors
Units = sectors of 1 * 512 = 512 bytes
Sector size (logical/physical): 512 bytes / 512 bytes
I/O size (minimum/optimal): 512 bytes / 512 bytes
Disk identifier: 0x48350995

   Device Boot      Start         End      Blocks   Id  System
/dev/sda2        61239296   125128703    31944704   83  Linux
/dev/sda3       125130751   234441628    54655439    f  W95 Ext'd (LBA)
/dev/sda4        52854784    61239295     4192256    7  HPFS/NTFS/exFAT
/dev/sda5       125130752   204957263    39913256   83  Linux
/dev/sda6       204957333   232315956    13679312   83  Linux
/dev/sda7       232315965   234441628     1062832   82  Linux swap / Solaris

Partition table entries are not in disk order

How to address this problem? Please tell me if my information is not enough. I don't know exactly what information is related to or needed to solve this problem. Leak of knowledge about this problem also makes me difficult to google it.

UPDATE

It seems this problem appeared after I tried to make 2 new ntfs partitions when another partition is in use (i.e. current Ubuntu partition). I reproduced the scenario and got this message when creating one of them:

GParted 0.11.0 --enable-libparted-dmraid

Libparted 2.3

Format /dev/sda4 as ntfs  00:00:02    ( ERROR )
    calibrate /dev/sda4  00:00:00    ( SUCCESS )
        path: /dev/sda4
        start: 52,854,784
        end: 61,239,295
        size: 8,384,512 (4.00 GiB)
    set partition type on /dev/sda4  00:00:02    ( ERROR )
    libparted messages    ( INFO )
        Error informing the kernel about modifications to partition /dev/sda3 -- Device or resource busy. This means Linux won't know about any changes you made to /dev/sda3 until you reboot -- so you shouldn't mount it or use it in any way before rebooting.
        Failed to add partition 3 (Device or resource busy)

I've rebooted, but there was no change.

share|improve this question

2 Answers 2

up vote 0 down vote accepted

try this from the command line:

sudo fsck.ext4 -f /dev/sda6

You can ask the system to check at next reboot by typing:

sudo touch /forcefsck

Good luck

share|improve this answer
    
The first fsck.ext4 execution worked :), but after I opened GParted and click Refresh Devices (Ctrl+R), /dev/sda6 was back to previous problem and fsck.ext4 said "No such file or directory while trying to open /dev/sda6". –  BornToCode Aug 8 '12 at 1:36
    
Did you reboot and allow the diskcheck? before opening Gparted?? If not, I suggest you try that, Regards Mal –  Malee Aug 8 '12 at 12:50
    
Oh, I got it. (1) Do the scenario above (partitioning in GParted) and got error message (2) sudo touch /forcefsck (3) reboot (and allow fsck). It solved my problem about the "lost partition". But the ntfs partitions is still error: GParted said "unknown", fdisk said the System is "HPFS/NTFS/exFAT". –  BornToCode Aug 8 '12 at 23:53
    
Whilst gparted can often resolve ntfs partition errors. You may be best to let windows do it for you. One easy way to do it is. Boot to windows - open my computer - right click the drive (repeat if more than one) - properties - disk tools - (memory here for me) fix errors - you will see two areas you can "tick" just tick the top one for now. This will run chkdsk /f on your drive(s). If this fixes it OK if not repeat the process and "tick" both boxes this runs chkdsk /r on the drive(s). Of course there are many other ways to get to "dos" and do this. –  Malee Aug 10 '12 at 5:11

I would expect this behaviour if you haven't actually formatted /dev/sda6 yet. Of course if you've put your data on it since you created it it must be formatted and you shouldn't reformat it.

I should explain that sudo fdisk -l does not verify that a partition has been formatted. The items like "linux" and "W95 Ext'd (LBA)" represent flags in the partition table (or extended partition information in this case) and have nothing to do with the actual contents of the partition. They represent what you told the disk partitioner what you intend to do with the partition. If you haven't yet formatted a partition the partition will contain random data.

A superblock is a part of the formatting of an ext file system within a partition. It must exist to use the file system.

I don't think this has anything to do with any of the other partitions.

This theory may be at odds with your comment on user13509's answer. I can't explain why sometimes fsck.ext4 could sometimes read /dev/sda6 and sometimes not. By the way, before you run it you must have the partition unmounted and must execute fsck.ext4 with sudo.

share|improve this answer
    
/dev/sda6 contains other Linux OS (formatted), but it was not mounted. Thanks John, although I still can't solve my problem, your answer extended my knowledge. –  BornToCode Aug 8 '12 at 5:32

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.