Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I have Ubuntu 12.04 installed on my Lenovo ThinkPad T420S.

In BIOS I have an option to select graphical card: integrated intel card or NVS 4200M (or NVIDIA Optimus which is out of scope now).

When I select integrated intel card in BIOS everything works fine. When I select nvidia system freezes after grub screen. Sometimes I get weird "ATA revalidation failed". Magic button (Alt+Fn+SysRQ+E/I/S/U/B) doesn't work.

What I have tried:

  1. Installing recent nvidia-current from x-swat ppa.
  2. Purging nvidia-current and nvidia-common
  3. Updating T420s BIOS version.
  4. Updating kernel to 3.4.7.
  5. Booting old kernel 3.2.0-18.

Nothing helps.

I don't think this is hardware issue since Windows works fine.

Any ideas?

share|improve this question
    
Subscribe to this [bug] on launchpad, I hope they will fix it. [bug]: bugs.launchpad.net/ubuntu/+source/linux/+bug/1083738 –  Andrey Dec 14 '12 at 13:59
add comment

1 Answer

I am having the exact same issue here. While trying to fix it, I pretty much did what you tried (upgrading to kernel 3.3 only) and even completely re-installed ubuntu. However, before the reinstall I still had a 3.0 kernel installed and booting into that, the nvidia was functional.

Conclusion: if you are willing to downgrade your kernel even further, the 3.0 kernel should still be working with the NVS 4200M...

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.