Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I have installed dockbarx using an article at omgubuntu. http://www.omgubuntu.co.uk/2010/12/new-look-dockbarx-hits-ppa/. The problem is that the window preview feature is not working.

UPDATE: While running dockbarx_factory.py run-in-window , i get the following warning:

 ** (dockbarx_factory.py:3820): WARNING **: Trying to register gtype 'WnckWindowState' as enum when in fact it is of type 'GFlags'

** (dockbarx_factory.py:3820): WARNING **: Trying to register gtype 'WnckWindowActions' as enum when in fact it is of type 'GFlags'

** (dockbarx_factory.py:3820): WARNING **: Trying to register gtype 'WnckWindowMoveResizeMask' as enum when in fact it is of type 'GFlags'
Dockbarx init
Dockbarx reload
Opened window matched with gio app on id: empathy
Opened window matched with gio app on id: gnome-terminal

.

alt text

How can i enable the preview?.

share|improve this question

2 Answers 2

up vote 4 down vote accepted
  • To use the window previews,you need CompizConfig Settings Manager

    sudo apt-get install compizconfig-settings-manager

  • Warning: What are some of the issues with ccsm and why should I not use it?

  • Also in gnome enable KDE Compatibility plugin System>>Preferences>>CompizConfig Settings Manager.

  • Once you enable this plugin, in DockBarX preferences goto Applications>>Accessories>>DockBarX>> Preference), on the Window List tab, enable Show Previews.

alt text

share|improve this answer
    
@karthik: Yes .I have already done this. Still the preview is not working. –  aneeshep Dec 14 '10 at 6:49
    
Just to confirm, this did work for me. –  Jamie Schembri Dec 15 '10 at 10:36
    
@aneeshep Press ALT+F2 and type the following without quotes "compiz --replace && killall gnome-panel" –  karthick87 Dec 18 '10 at 7:56
    
@karthik: it is also not working. At last i got it working by reinstalling the os. –  aneeshep Feb 16 '11 at 5:09
    
interesting answer for ubuntu but what about those running xfce or xubuntu? xfce comes with a compositor so there should be no need to run compiz. correct? –  Joshua Robison Feb 14 at 5:54

I've just figured this out myself, so.

Open Compizconfig Settings Manager (System>>Preferences).

Navigate to tab "Extras".

Select "Window Previews".

Hope this works for you :)

share|improve this answer
    
@Valis: I have tried this too. But no use. Still i can't get the preview. –  aneeshep Dec 15 '10 at 5:15
    
This does indeed show previews, however they're not the DockBarX integrated ones. For those, see karthick87's answer. –  Jamie Schembri Dec 15 '10 at 10:37

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.