Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I'm trying to build the kernel for Intel Core i7 following the steps from http://duopetalflower.blogspot.ro/2011/10/custom-64-bit-ubuntu-kernel-31.html (similar duopetalflower.blogspot.com.es/2010/10/ubuntu-maverick-64bit-kernel.html and www.n00bsonubuntu.net/content/how-to-build-linux-kernel-3-2-0-7-13-for-i7-systems-on-ubuntu-11-10/) on a LinuxMint 13 (Maya) 64-bit machine.

I tried 3 different versions 3.4.7, 3.5 and 3.6-rc1, always applying the associated Ubuntu patches but I always got the same error. The error occurs when trying to build the common header and source debs using

skipabi=true skipmodule=true fakeroot debian/rules binary-indep.

The error is caused by the missing of makefile for hv_kvp_daemon.c (An implementation of key value pair (KVP) functionality for Linux) from folder

linux/tools/hv

How this issue can be solved?

LINK perf
GEN perf-archive
GEN python/perf.so
make[1]: Leaving directory `/home/anv/Kernel/3.5/linux-3.5/debian/build/tools-perarch/tools/perf'
if [ "amd64" = "amd64" ] || [ "amd64" = "i386" ]; then \
        cd /home/anv/Kernel/3.5/linux-3.5/debian/build/tools-perarch/tools/power/x86/x86_energy_perf_policy && make CROSS_COMPILE=; \
        cd /home/anv/Kernel/3.5/linux-3.5/debian/build/tools-perarch/tools/power/x86/turbostat && make CROSS_COMPILE=; \
        cd /home/anv/Kernel/3.5/linux-3.5/debian/build/tools-perarch/tools/hv && make CROSS_COMPILE= CFLAGS=-I../../include; \
    fi
make[1]: Entering directory `/home/anv/Kernel/3.5/linux-3.5/debian/build/tools-perarch/tools/power/x86/x86_energy_perf_policy'
cc     x86_energy_perf_policy.c   -o x86_energy_perf_policy
make[1]: Leaving directory `/home/anv/Kernel/3.5/linux-3.5/debian/build/tools-perarch/tools/power/x86/x86_energy_perf_policy'
make[1]: Entering directory `/home/anv/Kernel/3.5/linux-3.5/debian/build/tools-perarch/tools/power/x86/turbostat'
cc     turbostat.c   -o turbostat
make[1]: Leaving directory `/home/anv/Kernel/3.5/linux-3.5/debian/build/tools-perarch/tools/power/x86/turbostat'
make[1]: Entering directory `/home/anv/Kernel/3.5/linux-3.5/debian/build/tools-perarch/tools/hv'
make[1]: *** No targets specified and no makefile found.  Stop.
make[1]: Leaving directory `/home/anv/Kernel/3.5/linux-3.5/debian/build/tools-perarch/tools/hv'
make: *** [/home/anv/Kernel/3.5/linux-3.5/debian/stamps/stamp-build-perarch] Error 2
share|improve this question

closed as off topic by John S Gruber, Stephen Myall, Mitch, hexafraction, Tom Brossman Oct 12 '12 at 21:41

Questions on Ask Ubuntu are expected to relate to Ubuntu within the scope defined by the community. Consider editing the question or leaving comments for improvement if you believe the question can be reworded to fit within the scope. Read more about reopening questions here.If this question can be reworded to fit the rules in the help center, please edit the question.

    
So this turned out to be bugs.launchpad.net/ubuntu/+source/linux/+bug/977246. –  John S Gruber Oct 12 '12 at 15:03

2 Answers 2

Here's a commit from Andy Whitcroft from here for the missing tools/hv/Makefile. I hope it helps.

diff --git a/tools/hv/Makefile b/tools/hv/Makefile
new file mode 100644 (file)
index 0000000..ef87f85
--- /dev/null
+++ b/tools/hv/Makefile
@@ -0,0 +1,7 @@
+hv_kvp_daemon: hv_kvp_daemon.c
+
+clean:
+       rm -f  hv_kvp_daemon
+
+install:
+       install hv_kvp_daemon /usr/sbin/

See https://bugs.launchpad.net/ubuntu/+source/linux/+bug/977246.

share|improve this answer

Thanks, the makefile solved most of the problem! After I created the makefile

hv_kvp_daemon: hv_kvp_daemon.c
clean: rm -f hv_kvp_daemon
install: install hv_kvp_daemon /usr/sbin/

another error occured since it was no *.8 file on tools/hv/ folder. So I created hv_kvp_daemon.8 empty file and then the command ended successfully.

share|improve this answer
    
It looks like you have answered your own question (congrats). As this will likely become the accepted answer please edit to include the elements of other responses that helped you (or at least credit it). This will help future OP's to resolve the same issue. –  Stephen Myall Aug 14 '12 at 21:19

Not the answer you're looking for? Browse other questions tagged or ask your own question.