Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I've tried some solutions on here which did not work, there are no errors shown when I press the esc key whilst shutting down, and the animation gets stuck on the first dot if it don't press esc.

How do I fix this?

share|improve this question
    
You have tried to shut down the computer into a terminal with the shutdown command or you have tried clicking the appropriate button? –  Lucio Aug 7 '12 at 4:28
    
OK we need to know the error, So try to shutdown, when it will show ubuntu Logo then press UP key, so you will see the error or where does you system got stuck. –  shantanu Aug 7 '12 at 11:32
    
I will do this in a few minutes and get back to you. –  user81790 Aug 7 '12 at 15:12

2 Answers 2

Try shutting down using the terminal by running:

shutdown -h now

and check the output it gives you. Probably you have a daemon that for some reason is blocking the process.

Shutting down using the text mode should give you some hints.

Hope this helps.

share|improve this answer
    
Thank you for the review. Sorry about the bad English. –  j0N45 Aug 7 '12 at 11:54
1  
Hey, this didn't work. The same error remained; I could not shut down and was stuck, with no errors appearing when I used text mode. –  user81790 Aug 7 '12 at 15:11

Look at the man page for shutdown, it states for the -h (halt) option:

"Requests that the system be either halted or powered off after it has been brought down, with the choice as to which left up to the system."

So it is platform specific - some systems halt the machine (and don't power it down), other systems halt and power down the machine with the -h option. Try "sudo shutdown -P now" instead.

share|improve this answer
    
shutdown -Ph now is also a valid Ubuntu option. –  belacq Aug 7 '12 at 20:16

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.