Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

Is there anyway to configure Nvidia Powerimizer performance levels? My current setup has 3 power levels with the lowest one being 50mhz. The problem with this it that it lags compiz when it goes to the lowest performance level 0. Minimizing, maximizing, dragging windows, etc. are all sluggish when it's at the lowest level. Once powermizer leaves level 0 everything is very smooth and runs great.

Is there anyway for me to remove level 0 and just run Level the two higher levels 1/2? I don't want to complete disable powermizer, but I can't stand the lagging once powermizer goes into performance level 0. Setting the option "prefer maximum performance" fixes the problem as it disables powermizer, but the GPU is overkill at stock speeds for most desktop use @ 850mhz.

intel i5 2500k
asus gene-z z68
evga 560ti fpb (driver 295.40)
ubuntu 12.04 LTS x64

share|improve this question

2 Answers 2

You can configure Powermizer via Xorg config options, as described here. I remember reading about these options in the documentation (select your version and click on "See the README for more detailed instructions." on the next page), but I'm currently not able to find the right chapter.

Adding this option to your xorg.conf device section might work for you:

Option     "RegistryDwords" "PowerMizerLevel=0x2" "PowerMizerLevelAC=0x2"
share|improve this answer
    
Adding that command to my xorg.conf made my system hang after the splash screen. I had to go in with the live installer and remove the line for my system to boot properly again. And your links don't seem to work. Thanks for trying though. –  jeffrey Aug 7 '12 at 13:45
    
Actually, the values for all of those variables can change between different GPUs. So they will not work for example on an Nvidia 9500 but will on a 460 GT (This is just an example, not saying they will actually work or not work on any of the 2 video cards mentioned). –  Luis Apr 19 '13 at 21:21

This is apparently a hardware architecture problem on nVidia cards up through the 500 series. When driving dual displays, the card will always run in high-power mode.

Cards of the 600 series and newer apparently do not suffer from this problem.

Citation :

http://nvidia.custhelp.com/app/answers/detail/a_id/3017/~/gpu-runs-at-a-high-performance-level%28full-clock-speeds%29-in-multi-display-modes

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.