Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

Good day,

I am a ubuntu newbie and I am having trouble using an external 3.5" HDD. I did some reading about file systems and decided to format my new drive to ex3. After formatting, I could not read or write because I did not have permission. I have tried pysdm and tried chown but it is still not working. Please could someone provide me with a simple step-by-step "how to" on this?

Thank you, Andrew

share|improve this question
    
Can you sucessfully mount that disc? If so, have you tried: sudo chmod -R 777 "directory of hdd", this is only a test. Having a file with 777 permissions isn't secure. It's only intended to see what may be the problem –  LnxSlck Aug 7 '12 at 0:20
add comment

1 Answer 1

If nobody except you is using the drive, you can explicitly mount the drive in your home directory. I am assuming you are currently simply connecting the drive, and allowing the system to mount it automatically, which it does in the /media directory, one which is owned by root. If it were a permanent directory, then you could change the permissions, but it's dynamic, so you can't. Therefore, mounting it explicitly in /etc/fstab is the best way, I think.

For my instruction, I will assume a directory named "extern"; change this if you wish, but make sure to do so everywhere. I will also assume your login name is Andrew, just for the example.

Create a directory in your home directory (/usr/andrew) named extern.

Using the bash terminal, enter a command sudo blkid. Find your external drive in the list, and copy the UUID, hich is in the form of "########-####-####-############". To copy, highlight with the mouse, and press shift-ctrl-C.

Next, you need to edit a system file using a text editor such as gedit. To do this, enter the commmand gksudo gedit /etc/fstab. At the end of this file add one line like this, substituting the UUID from the clipboard for the "####..." field (one single line, not two!):
UUID=########-####-####-############ /home/andrew/extern ext3 rw,suid,dev,exec,noauto,async,nofail,user 0 0

Save the file, but don't close it yet.

Unmount the external drive using either sudo umount /dev/sda2, or whatever number the drive is, or use Nautilus to unmount it.

In the bash terminal, enter the command sudo mount -a; this will mount the drives specified in the file. If there are no errors, check the drive in ~/extern to see if it is present. If so, you can close the /etc/fstab file. If there are errors, insert a '#' in the first space of the added line, to disable it, and report back here.

I think you should now be able to use the drive, when it is present.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.