Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I have tearing on Lubuntu 12.04 32-bit (on Flash videos things are very bad). On Ubuntu 12.04 I don't have tearing.

When I use compiz there is no tearing but my machine is low-end and has a slow processor and graphics card so i dont want compiz. I want to find a solution to stop tearing without enabling compiz.

My graphics card is Nvidia 9400(m).

How can I fix this?

share|improve this question
add comment

2 Answers 2

up vote 0 down vote accepted

The solution was the following: I use cinammon ! And i don't have tearing at all ! Plus i have full fps (200+ on sauerbratten) cause i dont use compiz ! Now i have other problems ...with jack.

share|improve this answer
add comment

About the X-Swat PPA

Installing packages from the Ubuntu X-Swat PPA should help fix this problem. It provides newer versions of X.org components, including some drivers.

Before enabling this or any other PPA, you should familiarize yourself with the possible risks of using PPA's:

In this case, the potential security risk can probably be considered very minimal, since this PPA is owned by the same team that is in charge of officially packaged X.org in Ubuntu. While considered stable upstream, it's possible that you may have some stability or usability problems with these packages...but you're already having serious problems, so it's worth it to use the PPA.

Enabling the PPA and Upgrading Your Packages

Open a Terminal window (Ctrl+Alt+F2) and run these commands:

sudo apt-add-repository ppa:ubuntu-x-swat/x-updates
sudo apt-get update
sudo apt-get install nvidia-current

Reboot. Then open Nvidia X Server Settings:

  • You're using Lubuntu, so you'll probably find it in LXDE Menu > Preferences.
  • If you were running vanilla Ubuntu (with Unity / Unity 2D0, you could search for nvidia x server settings in the Unity dash.

You can use this utility to configure the display as you wish.

Source: http://www.noobslab.com/2011/09/nvidia-drivers-for-ubuntu-1110-oneiric.html (by "Umair")

share|improve this answer
    
WOW !!! Hey tearing is fixed now ! How is that ?? But i had the latest nvidia driver from those that was suggested by additional hardware drivers. Man thank you ! Frame rate is so high and i have no tearing ! –  digitalcrow Aug 7 '12 at 12:11
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.