Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I have a Asus eee PC 1001PX running ubuntu 12.04. Everything works well but the wifi is unstable. When I boot the wifi works fine, but after about 5-10 min it gets slow, disconnects etc and the computer starts to run slowly. The it is ok after reboot, for about 5-10 min.

Any ideas? I have tried everything I have found with google but nothing works. I have tried a few different wifi routers and it is always the same.

sudo lshw -class network


  *-network               
       description: Wireless interface
       product: AR9285 Wireless Network Adapter (PCI-Express)
       vendor: Atheros Communications Inc.
       physical id: 0
       bus info: pci@0000:02:00.0
       logical name: wlan0
       version: 01
       serial: 48:5d:60:7d:b8:66
       width: 64 bits
       clock: 33MHz
       capabilities: pm msi pciexpress bus_master cap_list ethernet physical wireless
       configuration: broadcast=yes driver=ath9k driverversion=3.2.0-27-generic-pae firmware=N/A ip=192.168.1.82 latency=0 link=yes multicast=yes wireless=IEEE 802.11bgn
       resources: irq:17 memory:fbff0000-fbffffff
  *-network
       description: Ethernet interface
       product: AR8132 Fast Ethernet
       vendor: Atheros Communications Inc.
       physical id: 0
       bus info: pci@0000:01:00.0
       logical name: eth0
       version: c0
       serial: bc:ae:c5:27:61:81
       capacity: 100Mbit/s
       width: 64 bits
       clock: 33MHz
       capabilities: pm msi pciexpress vpd cap_list ethernet physical tp 10bt 10bt-fd 100bt 100bt-fd autonegotiation
       configuration: autonegotiation=on broadcast=yes driver=atl1c driverversion=1.0.1.0-NAPI firmware=N/A latency=0 link=no multicast=yes port=twisted pair
       resources: irq:46 memory:f7fc0000-f7ffffff ioport:ec00(size=128)

thanks.

share|improve this question
add comment

1 Answer 1

Try changing the "WPA group rekey interval" on your WiFi router, this is working for me now. It was set to 2 before I changed it to 3600, the value is in seconds. This is working now, I tried disabling hardware encryption and power management, but that did not work.

I am now trying other combinations with enabling power management and hardware encryption, as these are desirable features on a netbook :)

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.