Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I run Ubuntu 12.04 on my netbook (Acer Aspire One D255E) and I have the following problem with the brightness settings: If I want to adjust the brightness with the fn-key, I can only change between three brightness steps, but my netbook has nine brightness steps.

If I adjust the brightness in the system settings, it works fine and I can choose between nine steps, so I know they are there. They are just jumped, when I use the fn-keys. The funny thing: If I click the fn-key like crazy, I can get to the steps between, too. Does anybody have an idea, what the problem might be?

Thanks!

share|improve this question
    
This also fixes the Brightness not being maximum at boot on Acer Aspire Happy 2. –  user83106 Aug 13 '12 at 14:26

1 Answer 1

up vote 3 down vote accepted

Easy fix. In the terminal:

gksudo gedit /etc/default/grub

You will find this line in the new opened window:

GRUB_CMDLINE_LINUX_DEFAULT="quiet splash"

Change it to:

GRUB_CMDLINE_LINUX_DEFAULT="quiet splash acpi_backlight=vendor"

Save and close the window and type this in the terminal:

sudo update-grub

Then reboot. Rejoice :)

share|improve this answer
    
It worked. Thank you! –  stankowait Aug 8 '12 at 15:15

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.