Ask Ubuntu is a question and answer site for Ubuntu users and developers. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I have just bought Lenovo Z570 and installed ubuntu 11.10 on it. I normally work on the machine with a distance of almost 1.5 feet but I can see vertical bars all over the screen. I have shown my laptop to friends but they couldn't notice the bars. I on the other hand cannot un-see them even though the pixel bars are small.

My resolution is set to 1366x768.

lshw returns following:

             description: VGA compatible controller
             product: 2nd Generation Core Processor Family Integrated Graphics Controller
             vendor: Intel Corporation
             physical id: 2
             bus info: pci@0000:00:02.0
             version: 09
             width: 64 bits
             clock: 33MHz
             capabilities: vga_controller bus_master cap_list rom
             configuration: driver=i915 latency=0
             resources: irq:42 memory:d0000000-d03fffff memory:c0000000-cfffffff ioport:3000(size=64)

I was thinking if its a driver problem because I saw a similar machine on display running windows and I found its display just fine. That machine had however, following device:

Name: AMD Radeon(TM) HD 6620G Chipset Type: ATI display adapter Approx. Total Memory: 3046 MB Display mode: 1366x768 (32-bit) (60/Hz)

I guess my display device is Intel based. Any idea if the problem can be solved or should I return my laptop?

share|improve this question
Do you have contact lenses or astigmatism? Can you get some camera photos, focused with macro if you know how to do it, at various distances? Please don;t use a phone camera; use a real digital camera(point-and-shoot is OK) – hexafraction Aug 6 '12 at 19:11
That's weird I have a Z570, use ubuntu 12.04 and have no problems, I'll compare my display output – Joshua Siret Aug 6 '12 at 19:19
capabilities: msi pm vga_controller bus_master cap_list rom – Joshua Siret Aug 6 '12 at 19:24
Joshua do you have same display device? where did you take this info from: msi pm vga_controller bus_master cap_list rom – baltusaj Aug 6 '12 at 19:26
you could try installing sudo apt-get install mesa-utils my graphics always worked but this installed the details... – Joshua Siret Aug 6 '12 at 19:29

My system settings for baltusaj:

enter image description here

The Graphics section was updated from:

sudo apt-get install mesa-utils

But it should work anyway as per default

share|improve this answer

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.