Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

It seems every Linux machine I've ever worked on, when the router was restarted, the computer required a reboot too. All the Windows machines rejoined the network just fine. Why won't my Linux computers recognize a restarted router without a reboot themselves?

EDIT: I run 10.04, it's a desktop, wired connection, the router is Windstream 2Wire I'm not sure what model but I did find "2701HG" on it. I'm not sure what PC hardware is relevant here, the motherboard?

share|improve this question
    
What model of router is it? I have never had this problem... –  Kevin Soviero Dec 14 '10 at 4:02
    
Mine too. But I assume my routers eth port is not correctly disabled on reboots. Hence Ubuntu (+kernel) does not notice. Therefore a manual NetworkManager disconnect and reconnect is required. –  mario Dec 14 '10 at 5:23
2  
Looks like you need to provide more information, ubuntu version, hardware of the PC and router, if its a wireless or wired connection. –  Phil Hannent Dec 14 '10 at 11:13
add comment

2 Answers

up vote 2 down vote accepted

It will.

If it doesn't, it seems you have encountered a bug or an error in the driver.

  • If this bug is in a proprietary wireless driver (see System → Administration → Additional Drivers), I'm afraid there's not a lot you can do about it apart from writing an email to the manufacturer.

  • If this bug is in an open source driver, you should report the bug so that it can be fixed. Usually, those bugs will be taken up-stream to the relevant developers, since Ubuntu doesn't provide the drivers themselves.

In the usual case, the network-manager will connect automatically to any wireless network within reach. It will roam you through different networks if you're moving around the house, it will detect which networks you've joined successfully and automatically connect you.

  • Network Manager will always keep you connected to some network, if at all possible.

If, in your case, the Network Manager doesn't automatically connect to your network after the connection has been lost, please ask a question about it here. Make sure to provide us with all the details about your connection, your wireless hardware and the drivers you use. Also, provide all the steps to replicate the problem.

Note: I talk about wireless networks, but this applies equally to Wired networks, 3G connections, Modem connections, even VPNs. To the Network Manager, they're all more or less the same.

share|improve this answer
    
My Administration menu has no option Additional Drivers. It does however, have the option Hardware Drivers. Upon clicking it, a window opens with a blank list and the words: No proprietary drivers are in use on This system. –  John Dec 14 '10 at 16:50
    
@John good, in that case you can file a bug! Make sure to follow the instructions provided in the Wiki very carefully. But please ask a question, e.g. "How do I maka Network Manager automatically connect to my network?", here first. Provide the detail me and other asked for. –  Stefano Palazzo Dec 14 '10 at 18:55
    
I edited my question to add more details, don't know if you saw that or not. Yes, I will ask that question. As well as "How can I find out what network driver I'm using?". –  John Dec 14 '10 at 23:18
add comment

you might need to restart network-manager if you're on a desktop system

sudo service network-manager restart

share|improve this answer
    
May work, but he shouldn't have to do this. –  Stefano Palazzo Dec 14 '10 at 18:57
    
Restarting network manager is certainly preferable to rebooting the machine. He may be able to get this same effect by disabling/enabling the connection in the network manager applet without needing to go to a command line. –  ImaginaryRobots Dec 14 '10 at 20:05
    
Most of my connectivity issues of not being able to connect to/discover networks or having networking disabled altogether are usually resolved by restarting network-manager. I think it has other dependencies which are also restarted when you do that. –  shroff Dec 15 '10 at 1:39
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.