Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I have a small living room PC (Bohica, running fully-updated Ubuntu 10.10/Maverick) connected to my HDTV that I use for web browsing and media streaming. It connects via WiFi (wlan0) to my Fedora server (Snafu) that in turn connects to the internet. I use static addressing, and everything has been working fine.

I just got a Blu-ray player, and I'd like to give it wired network access to the internet via Bohica's available wired ethernet port (eth0). So far, I haven't been to get eth0 and the network configured to get the Blu-ray player talking to the internet.

Here's my wlan0 configuration:

 ip4 addr: 192.168.0.100
 mask:     /24 (255.255.255.0)
 gateway:  192.168.0.4 (fedora box)

The Blu-ray player is set to an IP of 192.168.0.98/24, with the same gateway as above.

I want eth0 set to an IP of 192.168.0.99/24, but when I do this using nm-connection-editor I lose internet access (the system tries to use eth0 as the default internet access interface).

How do I get my blu-ray player to talk to the internet through Bohica, and do so without disrupting my current (working) network?

Thanks.

Edit: Here's the relevant output from nm-tool with the Blu-ray player connected:

$ nm-tool

NetworkManager Tool

State: connected

- Device: eth0
  Type:              Wired
  Driver:            forcedeth
  State:             disconnected
  Default:           no
  HW Address:        90:FB:A6:2C:94:32

  Capabilities:
    Carrier Detect:  yes
    Speed:           100 Mb/s

  Wired Properties
    Carrier:         on

- Device: wlan0  [wlan0] 
  Type:              802.11 WiFi
  Driver:            ndiswrapper
  State:             connected
  Default:           yes
  HW Address:        00:26:5A:C0:D0:05

  IPv4 Settings:
    Address:         192.168.0.100
    Prefix:          24 (255.255.255.0)
    Gateway:         192.168.0.4
share|improve this question
    
Do I need NAT/MASQ on eth0? I thought not, since it is already active for wlan0. –  user7320 Dec 14 '10 at 3:44
    
I just followed the recipe here, but no change: ubuntuforums.org/showthread.php?t=713874 –  user7320 Dec 14 '10 at 3:59
    
Erased the above and tried firestarter, same result. Specifically, when eth0 is enabled, pinging Snafu (912.168.0.4, my gateway, via wlan0) yields "Destination Host Unreachable". Disable eth0, and the ping works. –  user7320 Dec 14 '10 at 4:58

2 Answers 2

up vote 4 down vote accepted

Turns out all I needed was firestarter Install firestarter. It quickly and easily did exactly what I needed, and nothing more.

share|improve this answer

You will need to set up routing or bridging on your living room PC (but you already know this, because you have a working Fedora Server acting as a router).

I think that you will need to bypass the gui and easy networking tools to get the network config that you want. I haven't seen the "Share this interface" (you know, like on Windows) setting in the gui or easy networking tools on my Ubuntu systems. I haven't looked real hard, so I may have missed the setting.

First, plug the blu-ray device directly into your Fedora Server. Make sure it works in the simple case. This may involve borrowing a long network cable or a second TV, but you really need to reduce the number of variables.

Next, decide on Bridging vs. Routing. Bridging would make the network configuration a bit easier, but in my experience, routing is easier to enable on the gateway host. Routing is usually a kernel option, and you would need to plan out a multi-subnet network. Bridging usually involves installing a package and then configuring it.

Now, look up how to configure your choice (Bridging vs. Routing) on Ubuntu 10.10. I suspect this is where you will need to leave networkmanager behind. It seems clear that network manager is disabling your wlan0 when it has a "better" eth0 connection. I'm not sure how to make network manager stop that, but I suspect the steps for enabling routing and bridging will have you disable network manager.

Finally, test your config. If the blu-ray player is lacking in diagnostic tools (like ping, traceroute, netstat -rn, ifconfig, access to the /etc/resolv.conf equivalant), you may need to borrow another computer (any friends with laptops?) to test.

I know I haven't outlined a step by step, but I hope I provided some additional clues to help resolve the problem.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.