Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I have a 32" Vizio HDTV. It's a few years old, but running well. I just connected a new nettop to it using HDMI out. It's the Intel 3x00 graphics chipset.

I'm seeing overscan, where the resolution in Ubuntu is set to 1280x720, but the TV itself is 1366x768. When I go into the Monitors control applet, I cannot change the resolution to anything other than the current or 640x480.

A user had a similar overscan problem, but fixed the overscan by adjusting his TV's aspect ratio settings. I do not have that luxury.

Is there a way I can do this without having to delve into xorg.conf or other command-line craziness? I'm more than comfortable doing so, but there must be a cleaner way.

I'm running Ubuntu Natty, keeping up with updates and such.

Here's the output of lspci:

colin@bricktop:~$ lspci
00:00.0 Host bridge: Intel Corporation Core Processor DRAM Controller (rev 12)
00:02.0 VGA compatible controller: Intel Corporation Core Processor Integrated Graphics Controller (rev 12)
00:04.0 Signal processing controller: Intel Corporation Core Processor Thermal Management Controller (rev 12)
00:16.0 Communication controller: Intel Corporation 5 Series/3400 Series Chipset HECI Controller (rev 06)
00:1a.0 USB Controller: Intel Corporation 5 Series/3400 Series Chipset USB2 Enhanced Host Controller (rev 06)
00:1b.0 Audio device: Intel Corporation 5 Series/3400 Series Chipset High Definition Audio (rev 06)
00:1c.0 PCI bridge: Intel Corporation 5 Series/3400 Series Chipset PCI Express Root Port 1 (rev 06)
00:1c.1 PCI bridge: Intel Corporation 5 Series/3400 Series Chipset PCI Express Root Port 2 (rev 06)
00:1c.2 PCI bridge: Intel Corporation 5 Series/3400 Series Chipset PCI Express Root Port 3 (rev 06)
00:1d.0 USB Controller: Intel Corporation 5 Series/3400 Series Chipset USB2 Enhanced Host Controller (rev 06)
00:1e.0 PCI bridge: Intel Corporation 82801 Mobile PCI Bridge (rev a6)
00:1f.0 ISA bridge: Intel Corporation Mobile 5 Series Chipset LPC Interface Controller (rev 06)
00:1f.2 SATA controller: Intel Corporation 5 Series/3400 Series Chipset 4 port SATA AHCI Controller (rev 06)
00:1f.3 SMBus: Intel Corporation 5 Series/3400 Series Chipset SMBus Controller (rev 06)
00:1f.6 Signal processing controller: Intel Corporation 5 Series/3400 Series Chipset Thermal Subsystem (rev 06)
01:00.0 Ethernet controller: Realtek Semiconductor Co., Ltd. RTL8111/8168B PCI Express Gigabit Ethernet controller (rev 06)
02:00.0 USB Controller: NEC Corporation uPD720200 USB 3.0 Host Controller (rev 03)
03:00.0 Network controller: Atheros Communications Inc. AR9287 Wireless Network Adapter (PCI-Express) (rev 01)
share|improve this question

4 Answers 4

up vote 1 down vote accepted

You may be able to use xrandr to add a new mode to the specific output and then select that new mode. See xrandr --addmode and xrandr --mode in the xrandr manpage.

share|improve this answer
    
I think this is the most correct. I tried this and IIRC it worked. I no longer have the TV, though -- replaced it with a 1920x1080 47". –  Colin Dean Apr 1 '11 at 14:10

It would seem a bit weird for a TV to have 768 lines: HDTVs are usually 720 or 1080 lines, so if the computer thinks the screen is 720 lines I'd be inclined to think it is correct.

Is it possible that the TV itself has some options to scale the input? Check to see if there is a "full pixel" or "100%" option, or something similar that will let the display the image over the full screen.

share|improve this answer
    
Many TVs have displays which are actually 1366x768. –  Colin Dean Apr 1 '11 at 14:09

I want to kill the set-top makers for being cheap bastards by keeping analogue thinking in the digital era. We don't need or want overscan on our digital TV-sets. On several TV:s overscan is the default behaviour. And setting the aspect ratio on the TV to "Just scan" because the graphics card still believes that it needs to scale the image and then the TV "fixes" it to fit the display. This makes the contents of a window to flicker when moving it.

I have a AMD Radeon card in my PC, but I believe the root problem is the same on your computer too. It took me several days to figure this one out. The TV behaves differently based on what the label on the HDMI port is set to.

If it's set to "Dvd" or something like that, it signals thru the HDMI cable that "Yes, I want overscan." because some old boxes used some scan-lines to send extra data, like subtitles.
If it's set to "PC" it will signal "No thanks, send it as it is." and act accordingly.

So, on my LG TV-set I had to:
1. Enter the TV menu and select "Option".
2. In the Option sub menu I had to go down and select "Input Label".
3. And finally I set the label on the HDMI port, where my PC were connected at, to "PC"

No more rescaling issues.

share|improve this answer

Maybe you can try the --pos option of xrandr. See the answer from Vadim Rutkovsky to this question: Geforce GT240M: How to disable Notebook screen and enable external Monitor

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.