Ask Ubuntu is a question and answer site for Ubuntu users and developers. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I recently installed Ubuntu 12.04 on my laptop but my wireless mouse is not working on it. I have Windows 7 installed on my laptop but my mouse is working properly on it. my mouse is 2.4 GH Generous what should I do??

share|improve this question
Please can you run the following "lsusb" "dmesg | grep -i usb" and "dmesg | tail -20" and add the output to the question? – Sparky Aug 6 '12 at 10:41

If you are still facing this issue, check the modules or drivers and uninstall/replug the device and see. I had the same issue where the wireless mouse was getting identified as Mosart semi 2.4G wireless but it just would NOT work!!!

And then tried the windows way of troubleshooting - uninstall/re-install drivers (pun intended) all I did was modprobe -r usbhid and plugged the nano receiver with skepticism.....but to my surprise it started to work again. I had spent close to 1-1.5 months trying to get this work and in the end all that was needed was to uninstall the driver :)


  1. Unplug dongle.
  2. Run modprobe -r usbhid on the command line.
  3. Plug dongle again.
share|improve this answer
this worked for me, also for Mosart 2.4G Wireless – Asaf Apr 15 '13 at 6:43

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.