Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

Inspired by this article:

http://m.linuxjournal.com/content/swap-your-laptop-ipad-linode?page=0,3

I have tried to emulate the set up of an ipad connecting to a ubuntu box hosted by linode. Everything works fine apart from the GNU screen switching with Ctrl-A. As the author explains:

"Ctrl-X is my screen's "hot key"; it defaults to Ctrl-A, but on a wireless keyboard, that leaves Unicode characters in the terminal—I assume this is related to Apple's support for some common Emacs keybindings in iOS. It's strange, but easy enough to work around"

Easy enough, he says, but it has defeated me! I have tried bind, but can't seem to control the Ctrl keys, and am reluctant to use xmodmap as I don't want to use any graphical output. The apple wireless keyboard doesn't seem to allow any system kep map settings either.

Everything else works beautifully, so this seems like such a silly place to get stuck.

share|improve this question
add comment

1 Answer 1

up vote 0 down vote accepted

I have the answer from the man himself, what a helpful guy! He has this alias in his bash.rc:

alias s="screen -DRe^Xx work"
share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.