Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

In Xubuntu 12.04 I want to place workspace switcher on a vertical panel to give myself more space on the top panel for the window list buttons. The problem is that the workspace switcher is still shown horizontally on the vertical panel. It would be great if the two workspace buttons were displayed vertically one on top of another.

share|improve this question
    
I have the exact same problem and there is no way to edit the workspace names... it's blanked out in the workspace settings preferences... Also switching off miniature view will give me vertical workspaces but... I really want to use miniature view –  Joshua Robison Dec 2 '12 at 12:45
add comment

1 Answer

Ok, some options, but for some reason the "row" setting is not taking effect on the vertical... I suspect you have found a bug.

enter image description here

  • Use only 2 workspaces (not the best I'll admit)

    enter image description here

  • Uncheck "Show miniature view" when you > right click > properties - on the workspace switcher.

enter image description here

This will give you workspace "buttons", but the text is still the other way...

enter image description here

Hope this helps, I will try to look into if there is a bug report already. Try Updating and creating a new user, the bug seems to be fixed in later versions.


To Change the name of the workspace- right click on the workspaces and select "Workspace Settings..." then double click on the right numbers to rename the workspaces. enter image description here

share|improve this answer
    
I have tried unchecking "show miniature view" - but it doesn't look good at all. I am curious how you got the 2 workspaces to lineup vertically. In my case the two workspaces are shown horizontally. –  ahamkah Aug 7 '12 at 1:47
    
The "Number of rows" option should do the trick, change that to 1. Ideally this should also affect it when you have more workspaces too (that's the part that is a bug). Also how wide is your panel, If this is still not working I'll try to reproduce your results. –  Mateo Aug 7 '12 at 9:05
    
Ok, I was all the time looking in the workspace settings. Now I saw the workspace switcher properties. It works if I select 1 row in the properties and I tried up to 4 workspaces and all lined up vertically. But in the process of changing these things I ended up with really small buttons for each workspace. Anyway, thanks for your help. I am back to using two horizontal panels. I really thought for a while that a vertical panel is a good idea. But soon I realized I need the complete width of the screen to tile up different windows, specially when coding. –  ahamkah Aug 8 '12 at 2:56
    
Oh, It lined up 4 on top of each other for you? It must be my computer on that... –  Mateo Aug 8 '12 at 3:00
    
I have the same problem but I really want to have vertical workspaces and use miniature view –  Joshua Robison Dec 2 '12 at 12:46
show 2 more comments

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.