Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free.

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I tried installing Ubuntu 12.04 server on my laptop using a USB stick !!

When it reached the base system installation I received this error !

                           Debootstrap warning

warning: file:///cdrom/portal/main/t/tzdata/tzdata_2012b-1_all.deb was corrupt

then it sends me back to the menu where I can choose either to install the base system again or proceed without installing it.

The same thing happened when I tried to install Xubntu 12.04 alternate on the laptop. Although I can install the Xubuntu using the Normal iso (GUI installation) with no problems !

I used md5sum and there were no errors. Searched the internet and I found the same error but with a different package corrupted. Tried their solution which basically choosing ext3 instead of ext4 and still no hope.

Do you think it is because of the Usb ? I mean should I use a CD instead ?

My laptop specs:

HP dv6

Ati Radeon HD 6600M

Processor: AMD A6 Quad Core

Any suggestions ?!!

share|improve this question
It looks like you need to try a CD, although I don't know why it booted until this error. – hexafraction Aug 5 '12 at 23:49
up vote 0 down vote accepted

I'd do this:

  • boot from the USB stick
  • select your language, I'll use English as an example

From the proceeding menu, select:

  • Check disk for defects

This will verify the installation source is Ok and can be read from the media. If it fails, reboot the system from the USB stick and this time select:

  • Test memory

On more than one occasion, I've found issues to with setup failing to read installation files due to bad / flaky RAM.

RAM tests will take a long while to run but if you let it complete at the very least you can rule out bad media and RAM as a source of your issue.

share|improve this answer
I checked the disk and found an error. So I used another USB and the problem was solved Thanks – Suhaib Aug 11 '12 at 7:38

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.