Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I found this package for latex that gives me the ability to typeset organic structural formulae and reaction schemes for chemistry. I'm having trouble with installing it though.

I read through the installation steps in the manual and it tells me that I need to edit the install.cfg.UNIX file which contains:

[PATH]
BINDIR=/usr/local/ochem
M4BINDIR=/usr/bin
INCDIR=/usr/local/ochem
DVIPSDIR=/usr/local/tetex/dvips/ochem
STYLEDIR=/usr/local/tetex/tex/latex/ochem
MODULDIR=/usr/local/ochem
DOCDIR=/usr/local/ochem/doc

[SYSTEM]
SYSTEM=UNIX

So I edited the file to this:

[PATH]
BINDIR=/usr/share/ochem
M4BINDIR=/usr/bin
INCDIR=/usr/share/ochem
DVIPSDIR=/usr/share/texmf-texlive/dvips/ochem
STYLEDIR=/usr/share/texmf-texlive/tex/latex/ochem
MODULDIR=/usr/share/ochem
DOCDIR=/usr/share/ochem/doc

[SYSTEM]
SYSTEM=UNIX

When I try to install the package, it says that it works, but when I try to typeset one of the examples, it tells me that it can't find ochem.sty. I then tried navigating to the directories that the install was supposed to make and they didn't exist. So I made the directories manually and tried the install again. I still get the missing ochem.sty error.

Did I edit install.cfg.UNIX correctly? My latex distribution is texlive 2009 on Ubuntu 10.10.

EDIT: I did try running sudo texhash and it still doesn't work.

share|improve this question

3 Answers 3

Check if it will work if you have a copy of ochem.sty in the same location as your latex source file it is likely located in /usr/share/texmf-texlive/tex/latex/ochem, if this works then it is likely that you need to just run; sudo mktexlsr in your terminal for latex to re-examine all of your style files,

share|improve this answer

You have to run sudo texhash to update LaTex database of local packages. Without this, LaTeX can't find them.

share|improve this answer
    
I tried that and latex still can't find the ochem.sty file. –  user7175 Dec 13 '10 at 19:30

A workaround is to look for graphical packages using synaptic under the term "chemistry."

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.