Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I upgraded my system from 11.10 to 12.04. After pressing the Power On button, I don't get the Ubuntu boot screen with the dots. All I get to see is a full black screen until the login screen is displayed. I have a Lenovo T420. I have also enabled the LUKS encryption and currently, I type the LUKS passphrase on a full black screen which is accepted and the system continues to boot. Is this a known issue on ubuntu 12.04 ? Is there a known fix for this issue ?

share|improve this question

1 Answer 1

I had the same problem when I installed.But soon I realized that this was caused due to graphics driver.After then I installed the required graphics driver and things came back to track.

Try one of them by setting in your grub.cfg I am not sure which one was the right one.

linux   /boot/vmlinuz-3.0.0-12-generic root=UUID=3e9185555-317f-4587-9b3c-d6b77262a598 ro recovery **nomodeset**

linux /boot/vmlinuz-2.6.37.6-0.9-default root=/dev/disk/by-id/ata-TOSHIBA_MK6465GSX_FHGJKHKH-part3 **splash=silent quiet showopts vga=0x317**

Only try those which are inside two asterisks ,and dont copy whole line, otherwise result could be weird.

share|improve this answer
    
I hardly remember what I did ,but perhaps kept vesa as default and then later I installed Intel HD driver.Please dont convict me as its now totally out of my mind. –  perilbrain Aug 5 '12 at 17:18
    
There was another related question askubuntu.com/questions/127130/splash-problem-with-ubuntu-12-04 where they pointed to byobu.info/wiki/Changing_Plymouth_Resolution_in_Ubuntu as the solution. I tried it, but that didn't work as well. I was left with a Gnome 3 classic only ubuntu with a much lower resolution. I had to rollback the changes. –  Lakshmikanth Aug 5 '12 at 18:00
    
I have made some changes you can try one of them...Not sure about there 100% success. –  perilbrain Aug 5 '12 at 18:14
    
I tried adding nomodeset to /etc/default/grub and so, now it looks like GRUB_CMDLINE_LINUX_DEFAULT="quiet splash nomodeset". This one shows the plymouth during boot, but always boots me into gnome 3 classic only with a max resolution of 1024x768. I guess I am getting into the recovery mode by default. As for the second option, I am not able to see it in the grub.cfg at all. I am still stuck. –  Lakshmikanth Aug 6 '12 at 2:58

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.