Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I have SAPPHIRE HD 7770 and cannot get work audio over HDMI. http://www.sapphiretech.com/presentation/product/?cid=1&gid=3&sgid=1159&lid=1&pid=1452&leg=0

I use Ubuntu 12.04 LTS 64-bit version with all current updates.

I tried at /etc/default/grub: GRUB_CMDLINE_LINUX_DEFAULT="quiet splash radeon.audio=1" ... it didn't help. It's probably I use proprietary driver -this seems to be open source driver.

I use the driver, what jockey-gtk (additional drivers) offered me:

ATI/AMD PROPRIETARY FGLRX GRAPHICS DRIVER  <---- I installed that one

ATI/AMD PROPRIETARY FGLRX GRAPHICS DRIVER (post-release update)

So - I installed the first one, because installing second version failed.

Everything went fine but no sound at TV display by HDMI. Even Gnome sound mixer doesn't show HDMI choice. Using 32" Samsung B530 LCD TV - http://www.lcdbesttv.com/2010/02/samsung-b530-series-lcd-tv/

I have Asus P8Z77-M motherboard - http://www.asus.com/Motherboards/Intel_Socket_1155/P8Z77M/ - there is also HDMI integrated. When I put HDMI cord to that plug, then even Gnome sound mixer showed HDMI audio but it didn't work. I have set from BIOS, that I use that SAPPHIRE HD 7770 from PCIe.

My lspci output:

00:00.0 Host bridge: Intel Corporation Ivy Bridge DRAM Controller (rev 09)
00:01.0 PCI bridge: Intel Corporation Ivy Bridge PCI Express Root Port (rev 09)
00:02.0 Display controller: Intel Corporation Ivy Bridge Graphics Controller (rev 09)
00:14.0 USB controller: Intel Corporation Panther Point USB xHCI Host Controller (rev 04)
00:16.0 Communication controller: Intel Corporation Panther Point MEI Controller #1 (rev 04)
00:1a.0 USB controller: Intel Corporation Panther Point USB Enhanced Host Controller #2 (rev 04)
00:1b.0 Audio device: Intel Corporation Panther Point High Definition Audio Controller (rev 04)
00:1c.0 PCI bridge: Intel Corporation Panther Point PCI Express Root Port 1 (rev c4)
00:1c.5 PCI bridge: Intel Corporation Panther Point PCI Express Root Port 6 (rev c4)
00:1c.6 PCI bridge: Intel Corporation 82801 PCI Bridge (rev c4)
00:1d.0 USB controller: Intel Corporation Panther Point USB Enhanced Host Controller #1 (rev 04)
00:1f.0 ISA bridge: Intel Corporation Panther Point LPC Controller (rev 04)
00:1f.2 SATA controller: Intel Corporation Panther Point 6 port SATA Controller [AHCI mode] (rev 04)
00:1f.3 SMBus: Intel Corporation Panther Point SMBus Controller (rev 04)
01:00.0 VGA compatible controller: Advanced Micro Devices [AMD] nee ATI Device 683d
01:00.1 Audio device: Advanced Micro Devices [AMD] nee ATI Device aab0
03:00.0 Ethernet controller: Realtek Semiconductor Co., Ltd. RTL8111/8168B PCI Express Gigabit Ethernet controller (rev 09)
04:00.0 PCI bridge: ASMedia Technology Inc. ASM1083/1085 PCIe to PCI Bridge (rev 03)
share|improve this question
add comment

3 Answers 3

All you need to do is go on the AMD website and download the auto detect driver. Then it will automatically update your sound driver as well as the other drivers for the graphic card. It works right away and took me like 2 minutes. NEXT NEXT FINISH and bang.

share|improve this answer
add comment

Open your system settings then sound, and under hardware make sure your card is selected.

My PC tries to use its built in audio by default, changing this fixed a simmeler problem for me.

share|improve this answer
    
Now (30th April 2013) installed latest mainline 64-bit kernel 3.9.0-030900-generic from kernel.ubuntu.com/~kernel-ppa/mainline/v3.9-raring and latest ATI-AMD Catalyst 13.4 driver (driver: www2.ati.com/drivers/linux/… and release notes: support.amd.com/us/kbarticles/Pages/… and installation instructions can be found at ubuntukiller.com/2013/04/kernel-390-release-how-to-install.html) and HDMI sound works! This worked even without ATI-AMD driver, with new kernel only! –  zeroconf May 1 '13 at 1:01
add comment

It seems your fglrx module can't be loaded because of your motherboard's module is already loaded.

The same goes for the ALSA module for the HDMI audio on the Radeon card.

Simply disactivate your motherboard's onboard video, and you should be OK.

Generally, it's a good idea to disactivate your onboard video if you aren't using it. It will waste a good chunk of your RAM, and on intel i-series systems and AMD APUs will leave the GPU portion of your processor running unused, wasting power and more importantly, generating heat.

share|improve this answer
    
Can you explain in your answer how the OP can disable their onboard video? –  Kevin Bowen Feb 27 '13 at 10:30
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.