Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

On my Ubuntu 12.04 LTS, unwanted Asian language (I cant tell which) is set. Odd thing is I kept choosing English US all along, but I still get this garbage mixed in the icon definitions, Firefox icon is messed up, other arent, then top-left most menu description is gone. I saw this post

unwanted chinese language got set in system settings

But the fix described there did not work for me. I looked in my .profile, .bashrc, /etc/profile, there are no language settings there.

Any ideas?

share|improve this question
add comment

1 Answer

Okay, in /etc/default/locale I set this and it worked

LANG="en_US.UTF-8"
LANGUAGE="en_US:en"
LC_NUMERIC="en_US.UTF-8"
LC_TIME="en_US.UTF-8"
LC_MONETARY="en_US.UTF-8"
LC_PAPER="en_US.UTF-8"
LC_IDENTIFICATION="en_US.UTF-8"
LC_NAME="en_US.UTF-8"
LC_ADDRESS="en_US.UTF-8"
LC_TELEPHONE="en_US.UTF-8"
LC_MEASUREMENT="en_US.UTF-8"
share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.