Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

This has been bugging me for some time now... Laptop: Thinkpad T420 Ubuntu 12.04 Precise

When I installed Precise, I could use my webcam without any issue (Cheese, Skype...) However, all of a sudden (I suppose after an update) it stopped working, Cheese showing me "no device found", but stll shows up in lsusb

lsusb
Bus 001 Device 004: ID 04f2:b221 Chicony Electronics Co., Ltd integrated camera

However /dev/video0 does not exist...

I don't see how to debug this, I assume it must be easy since it used to work perfectly on this same machine and installation.

It is worth mentioning that the webcam is not damaged or disconnected as it is working flawlessly in my dual-boot windows partition. The only reason I boot on Windows now is to use Skype, since Ubuntu doesn’t allow me thus luxury...Any help would be greatly appreciated. Please let me know if you need more details.

Thank you!

share|improve this question
    
Can anyone help, please? I have a long distance relationship with my girlfriend and the simple fact that I can't use my webcam with Skype is really affecting it, and I'm not joking! –  R Pennese Sep 6 '12 at 18:57
    
ANd I just thought about something: would rebuilding my kernel help? –  R Pennese Sep 6 '12 at 22:38
    
Did this start recently or has it always been this way since you installed 12.04? –  computermacgyver Oct 16 '12 at 21:28
    
As I mention in the description, it worked fine when I Installed 12.04 and it appeared later, I suppose after an update –  R Pennese Oct 17 '12 at 4:12
    
I installed 12.10 and it worked from the start and after some update it just stopped working. lsubs: Bus 003 Device 002: ID 04f2:b2e1 Chicony Electronics Co., Ltd. Any pointers as to how to debug this will be very welcome. –  Fernando Briano Feb 26 '13 at 17:56
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Browse other questions tagged or ask your own question.