Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I have a catch 22 problem in trying to install this driver (NVIDIA-Linux-x86-302.07.run) to set my screen to its native resolution of 1280x1024 (hpL1906).

Problem is that in order to install this driver, I need to stop the XServer but when I do this (sudo service lightdm stop), my screen goes blank and displays the message -

Out of Range 1280X1024 need to reset

(or something similar) - and I can go no further.

So, I cannot install NVIDIA-Linux-x86-302.07.run without stopping lightdm but when I do so, I can no longer see anything on the screen or go further to install the driver that would let me adjust the resolution. Any advice on getting out of this loop would be greatly appreciated.

share|improve this question

2 Answers 2

You can install Nvidia drivers through Ubuntu Software Center or Jockey (Aditional Drivers). No need to install the .sh from NVIDIA.

share|improve this answer
    
Hi LnxSlck, did not want to cover material in other posts so did not give the history, but the Additional Drivers installed through Jockey were the cause of the initial problem resulting in a screen resolution so low (800x600) that the important icons were obscured and the program unworkable. It was only when the NVIDIA Driver was removed and the generic Linux/Ubuntu Driver took over that the program has become workable with resolution at 1024x768. The New Driver (NVIDIA-Linux-x86-302.07.run) does not appear as an option in Jockey. Will see how I go from Software Center. –  paj100 Aug 5 '12 at 6:47

I'm not sure if I understood your question entirely, but I think you can switch to a text-based instance of Ubuntu, stop the X Server and then install the package from there.

  1. Press Ctrl+Alt+F1 to switch to a text-based environment (F1 to F6 are text-based).
  2. Stop the X Server with sudo service lightdm stop.
  3. Install your package.
  4. Restart the X Server with sudo service lightdm restart.
  5. Press Alt+F7 to go back to the default graphical instance.

I'm kind of newbie in Ubuntu. I hope my answer helps.

share|improve this answer
    
This I have tried, the Ctrl+Alt+F1 command along with others in this series just blacks out the screen and displays the message - Out of Range 1280X1024 need to reset (or something similar) - and I can go no further without a Restart (Ctrl+Alt+Del). –  paj100 Aug 5 '12 at 6:20

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.