Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

See here for reference: http://okular.kde.org/news.php

The new version includes an option to save annotations to the PDF file itself. That's why I am very eager to try out. Is there any PPA from which I could install this new version?

Edit: Following 808sound's advice I managed to install Okular 0.15 on precise. The dependencies installed with the upgrade caused several issues with other programs. Fixing these issues required uninstalling Okular and downgrading packages that were upgraded with it. You might want to install Okular from the Kubuntu Backports PPA instead, although in this case you won't be able to export annotations to PDF. See below for more information. Please keep this in mind before choosing the source you want to install the latest Okular from.

Small remark: BlaXpirit's answer will provide you with the latest Okular minus the annotation feature. For this specific functionality to work you will have to follow 808sound's answer.

share|improve this question
1  
I could update poppler to 0.20 by temporarily adding a quantal repository. But there was no update offered for Okular. I have 0.15.0 installed, but the annotation saving does not work. I assume you require a version that was compiled with the appropriate libpoppler. The one in the quantal repositories does not seem to be. –  user334287 Aug 5 '12 at 10:30
    
Was about to look for a ppa etc; thanks a lot for your EDIT and the heads-up warning. Will re-consider (and/or proceed cautiously). –  nutty about natty Jan 20 '13 at 12:27
1  
@nuttyaboutnatty I'm glad you found this Q&A useful. One small remark though: Installing Okular from the Kubuntu backports PPA as outlined here works flawlessly (minus the annotation feature as this requires the new Poppler version). My problems arose when I tried to upgrade liboppler from the Quantal repositories. So if it's just an updated Okular you want you can go ahead without any major worries. –  Glutanimate Jan 20 '13 at 14:26
1  
I don't think this warrants a separate question, so just briefly here: I guess this bug / feature-request (about wanting a tabbed interface in okular) bugs.kde.org/show_bug.cgi?id=155515 is still (officially) not resolved, also in 0.15, right? –  nutty about natty Jan 20 '13 at 19:19
1  
@nuttyaboutnatty No tabs yet, unfortunately, no. –  Glutanimate Jan 20 '13 at 19:44

7 Answers 7

up vote 7 down vote accepted

I backported poppler 0.20.5 to Ubuntu 12.04, compiled Okular 0.16.2 (edit: now updated to 0.17) against it, and put them in a ppa. To use it, add the ppas ppa:kubuntu-ppa/backports and ppa:kalakris/okular:

sudo apt-add-repository ppa:kubuntu-ppa/backports
sudo apt-add-repository ppa:kalakris/okular

Now update the package index and upgrade okular:

sudo apt-get update
sudo apt-get install okular

This version allows me to export annotations to PDF. Since these packages are compiled for precise, there should be no trouble with other dependencies, unlike the solution that suggests installing packages from quantal.

share|improve this answer
    
Warning: one possible complication of this method is that applications that rely on the system standard release of libpoppler might start having problems. That's the case for Inkscape, for instance. If libpoppler is more recent than the one Inkscape was built against various PDF functions will stop working (e.g. PDF import and export). –  Glutanimate May 6 at 9:30

Please read the following paragraph very carefully. This answer shows a way to upgrade Okular to 0.15 (with support for exporting annotations to PDF) on Ubuntu 12.04. Note that (as the OP has mentioned) the other solution regarding the Kubuntu backports PPA will get version 0.15 of Okular but will NOT give you the functionality to export annotations to PDF, which was something that the OP wanted. Unfortunately, you will find that this new functionality in Okular 0.15 is a bit limited, and it may not encode certain types of annotations into your PDF documents. In addition, upgrading can cause compatibility issues with fonts, etc. Thus, you should think twice before trying this.

To continue and try Okular 0.15 for yourself, you may want to first make a file old_packages.txt containing a list of your currently installed packages/versions (if you forget this, don't worry):

sudo apt-get install aptitude
aptitude -q -F "%?p=%?V" --disable-columns search \~i > old_packages.txt

To prepare for the upgrade, add the following two lines to /etc/apt/sources.list

deb http://archive.ubuntu.com/ubuntu/ quantal main universe
deb-src http://archive.ubuntu.com/ubuntu/ quantal main universe

Then run the following commands:

sudo apt-get update
sudo apt-get install okular -f

If you get any errors, try this (repeatedly until the Okular install succeeds):

sudo apt-get install -f
sudo apt-get autoremove -f
sudo apt-get install okular -f

After, this typing

okular --version

should show version 0.15.x. Finally, to prevent unexpected stuff from getting added/upgraded, you should probably comment out the two added lines in /etc/apt/sources.list and do

sudo apt-get update

Please be warned that this procedure can cause other packages to be updated from the Quantal repository, creating compatibility issues with fonts, etc. The comments below this answer contain more information about this.

If you want to uninstall Okular 0.15 and undo all these changes to your packages, it is fairly straightforward. You should first do

sudo apt-get purge okular
sudo apt-get autoremove -f

At this point, you could use the old_packages.txt file you initially created to downgrade all of your packages to their previous versions (see here for the details). Or you can do the following nice procedure (detailed in an answer to a question about rolling back Ubuntu).

Edit /etc/apt/preferences and add the following

Package: *
Pin: release v=12.04
Pin-Priority: 1001

Finally, do

sudo apt-get dist-upgrade -f
sudo apt-get autoremove -f

You should now be back to your original 12.04 packages/versions.

share|improve this answer
1  
Thanks! Your solution worked out fine. I was pretty disappointed, though, that even in this new version, okular only supports export of the "note type" annotations. Other forms of review can't be saved to pdf. And a small headsup for other people that try this installation method out. After restoring the previous sources.list you might run into some font configuration issues (Error messages in terminal). Either reinstall the afflicted fonts or follow this tutorial to solve the problems: ubuntuforums.org/showthread.php?p=12159762#post12159762 –  Glutanimate Aug 17 '12 at 20:53
2  
Another important remark: I had several issues after adding the quantal ppas even though I immediately deactivated the sources after installing okular. The following packages were upgraded with the install and caused several problems (i.e. sluggish performance when playing back flash video): liblzma5, libfontconfig1, libfontconfig1:i386, fontconfig-config. Eventually I had to undo all the previous changes to restore functionality. All things considered I would advice against installing okular 0.15 on precise. –  Glutanimate Aug 17 '12 at 23:14
1  
Please also be aware of the fact that downgrading packages is no easy feat. In order to go back to how things were before the installation I had to manually downgrade each package using their respective .deb files. –  Glutanimate Aug 17 '12 at 23:16
1  
@Guanidene yes, I gave a very clear warning that things can go wrong when you try to do this with the Quantal repository. In addition, I referred to the above comments which explain that you don't really get the expected features. Please remove your downvote, or explain how I can edit the answer to address your concerns. –  808sound Feb 24 '13 at 15:06
1  
@Guanidene I'm sorry to hear about these issues. I've added some explanation/information to the answer, as well as a method(s) to downgrade packages back to their original 12.04 versions. Please take a look on your 12.04 installation and remove your downvote accordingly. –  808sound Feb 26 '13 at 4:50

That's easy. Add ppa:kubuntu-ppa/backports to your software sources and you'll be able to install KDE 4.9 software along with Okular 0.15.0

share|improve this answer
1  
This just works, thanks a lot! I have no idea why you had 0 upvotes before I voted you up. Seems the OP lost interest after the failed attempt of the accepted answer. –  Christian Aug 25 '12 at 10:14
    
It works fine as far as installing Okular 0.15 is concerned. The PDF engine Okular utilizes (libpoppler) is not upgraded in the process. As a result there is no way of exporting annotations to pdf. If you need that functionality you will have to follow through with the more complicated method provided above. –  Glutanimate Aug 26 '12 at 11:04
1  
@Christian there seems to be some confusion here. The OP asked for a method to install Okular 0.15 with ability to export annotations to PDF. As the OP mentioned, this answer does not provide that capability, while my answer does. In any case, I've clarified my answer, and added information about removing any detrimental changes made by the corresponding okular installation. Please remove your downvote! –  808sound Feb 26 '13 at 4:56
    
Sorry, I meant to say, whoever downvoted on Aug 25, please remove your downvote or explain what the problem is. Thanks! –  808sound Feb 26 '13 at 5:27
    
@808sound Sorry, I didn't realize that indeed. I came here because I just wanted to install Okular 0.15 and I was happy that there is this easy way. I didn't want to imply that this solution is better in any way than yours. It just did what I needed in the most simple way possible. People downvote much too lavishly. It wasn't me though :/ –  Christian Feb 26 '13 at 10:03

I followed the suggestion by user135805 and works flawlessly. Only difference to the tutorial pointed, I am using trusty and kubuntu backports repos. To sum up,

edit /etc/apt/sources.list:

deb http://archive.ubuntu.com/ubuntu/ trusty main restricted universe
deb-src http://archive.ubuntu.com/ubuntu/ trusty main restricted universe

edit /etc/apt/preferences.d/okular:

Package: okular
Pin: release a=trusty
Pin-Priority: 990

Package: libokularcore4
Pin: release a=trusty
Pin-Priority: 990

Package: libpoppler-qt4-4
Pin: release a=trusty
Pin-Priority: 990

IMPORTANT, edit: /etc/apt/apt.conf.d/00aptitude

APT::Default-Release "precise";

otherwise you will mess up your packages

edit: /etc/apt/sources.list.d/kubuntu-ppa-backports-precise.list

deb http://ppa.launchpad.net/kubuntu-ppa/backports/ubuntu precise main
deb-src http://ppa.launchpad.net/kubuntu-ppa/backports/ubuntu precise main
deb http://ppa.launchpad.net/kubuntu-ppa/backports/ubuntu trusty main
deb-src http://ppa.launchpad.net/kubuntu-ppa/backports/ubuntu trusty main

perhaps some of the entries in /etc/apt/preferences.d/okular are not needed, but it workded for me this way. After editing you have to do

apt-get update
apt-get install okular -t trusty

hope this helps.

share|improve this answer

The feature you quote seems to require poppler 0.20. I don't know if there's a backport for 12.04.

share|improve this answer

I've been able to have it working thanks to your own comment, so I'm writing here some more information. Hopefully this could help you and others. You should add Quantal repositories "main" and "universe", then update libpoppler packages, okular and libokularcore1abi1. Note that even if you previously updated Okular to 0.15 from ppa:kubuntu-ppa/backports (as I did), you can still update it once again after you added Quantal "universe" repository. Make sure that your Okular installation comes from Quantal repository, otherwise it won't work.

share|improve this answer
    
Hey, thanks for posting this. I am still a newbie with Ubuntu. Could you guide me through adding those repositories and installing the packages please? Also, is adding quantal repositories save? Does it interfere with the regular update progress? Or can you specifically choose which packages get updated through quantal and which through precise repos? Thanks in advance! –  Glutanimate Aug 6 '12 at 16:48

Another though lengthy way to do the installation is using package priorities with APT. This link really helps:

http://blog.sleeplessbeastie.eu/2012/10/08/ubuntu-precise-install-youtube-dl-package-using-quantal-repo/

Using that procedure you can install only the packages required for Okular to work and avoid the updating of other libraries. The annoying thing is that you have to set permissions one file at a time and it consumed quite a while because you have to install the whole KDE environment. At the end it was not that much but prepare to spend at least one hour in front of the terminal.

So far I have not had any conflicts and no other upgrades from quantal.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.