Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

Okay,so few months back I read a post somewhere, dont remember where but it was on how to disable the lock screen. Now that I disable whenever the monitor switches off the system hangs. I remember Editing using gedit to do that. How do I re enable Lockscreen? I'm not talking about just removing it from the menu, im talking about disabling it completely. How do I re enable it?

share|improve this question
    
When you make amends in the menu, it usually changes something in a file. If you deleted something in a file that doesn't sound good. Can you find out which file you changed, perhaps it's in recently used files in gedit? –  Joshua Siret Aug 4 '12 at 19:42
    
The problem is I made a while ago. And as far as I remember I didn't delete anything. I wrote something in the file like [Disable Lock Screen] some lines Instead of [Re-enable Lock screen] But I'm really not sure –  Schweinsteiger Aug 4 '12 at 19:45
    
Hmmm, you could start by locking the screen using Ctrl+Alt+L and check it's not a problem with suspend or sleep. Obviously save your work. –  Joshua Siret Aug 4 '12 at 19:46
    
The next thing I would do is to have a look at your log files, if something is throwing an error that would be nice. –  Joshua Siret Aug 4 '12 at 19:47
    
As I said, I didn't remove it from the menu. I Completely disabled it. So Ctrl + Alt + L doesn't work. But in power settings it locks screen after 10 minutes so the screen hangs. I have currently changed it to Never for now so that It doesnt hang but I want to get back the lock screen feature. –  Schweinsteiger Aug 4 '12 at 19:48

2 Answers 2

/etc/default/acpi-support deals with this sort of function. Perhaps LOCK_SCREEN=true is commented out with the #

# Set the following to "platform" if you want to use ACPI to shut down
# your machine on hibernation
HIBERNATE_MODE=shutdown

# Comment this out to disable screen locking on resume
LOCK_SCREEN=true

# Uncomment this line to have DMA disabled before suspend and reenabled
# afterwards
# DISABLE_DMA=true

If it is so, try uncommenting it and it might fix your problem, you might have to restart your computer too I should add.

share|improve this answer
    
Nope It was without the #. Just as you mentioned in the comment –  Schweinsteiger Aug 4 '12 at 20:03
    
Hmmm that's a shame –  Joshua Siret Aug 4 '12 at 20:04
    
blog.projectz.me/2012/06/25/… any help? –  Joshua Siret Aug 4 '12 at 20:05
    
I already tried that. Since that command line is for Disabling it, I used this gsettings set org.gnome.desktop.screensaver lock-enabled true Whereas in the post they asked us to use "false" –  Schweinsteiger Aug 4 '12 at 20:08
    
if you can cause the system to hang, by making the screen lock you might see an error in one of the files I mentioned ^^^^ up there –  Joshua Siret Aug 4 '12 at 20:11
up vote 0 down vote accepted

@Joshua How stupid of me. I had just turned lock screen off from Ubuntu tweak. Sorry for wasting your time.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.