Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I've installeb Matlab r2011a on ubuntu 11.10 today following Ubuntu's guide.

I've also followed the steps to create the launcher. It appeared, but when I click on it nothing happens. Does anyone knows what can I do to fix it?

Please keep in mind that I'm no expert in Ubuntu, I'm still getting used to it.

Additional info

I can run it perfectly trough terminal. My only problem is getting the launcher to work. To create the launcher I used these instructions:

  1. Get an icon:

    sudo wget http://upload.wikimedia.org/wikipedia/commons/2/21/Matlab_Logo.png -O /usr/share/icons/matlab.png
  2. Get the launcher file:

    sudo wget 'https://help.ubuntu.com/community/MATLAB?action=AttachFile&do=get&target=matlab-r2011a.desktop' -O /usr/share/applications/matlab.desktop
share|improve this question
How did you create the launcher? Also can you confirm that you can launch matlab from a terminal? –  mutzmatron Aug 4 '12 at 21:02
I can run it perfectly trough terminal. My only problem is getting the launcher to work. To create the launcher I used the instructions on <help.ubuntu.com/community/MATLAB#Create_A_MATLAB_Launcher>; I added the info you requested on the original message. –  Daniel Aug 4 '12 at 21:48
add comment

1 Answer

up vote 2 down vote accepted

Try specifying the full path in the launcher you are using.

So for example if the output of which matlab is /usr/bin/matlab, then change the Exec field to

Exec=/usr/bin/matlab -desktop

Note that if this does solve the issue for you it's likely because you have a script called matlab that is shadowing the original matlab command and so perhaps matlab is not receiving the -desktop flag which it needs to run when launched without a terminal.

See this entry for more details about getting the launcher to start properly by using -desktop.

If for some reason you still get nothing, try setting the type field to terminal application to diagnose the problem further.

share|improve this answer
I went to /usr/share/applications, right clicket on matlab and tried to change the execute command, without success. Everytime I closed it it returned to the defauld. Is there any way to do it using the terminal? –  Daniel Aug 4 '12 at 22:15
@Daniel: you need to do it as root. You can do this eg, using sudo gedit /usr/share/applications/matlab.desktop from a terminal (or using whatever other text editor you prefer) –  mutzmatron Aug 4 '12 at 23:03
add comment

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.