Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I had Ubuntu 11.10 and in the last few weeks I experienced an obscure problem: after I had the computer running for a few days I could no longer connect to google.com or anything related to google. All sites worked with all browsers (Firefox, chrome, opera) except google. It remained in the connecting phase for a few minutes and either timed out or finally connected with this huge delay.

Even if I entered other sites such as this one, if it had anything to do with google such adsense or gstatic or whatever with g in it, that site took a long time to load waiting in connecting to gstatic.com . Anything google related took minutes to work, but everything else worked instantly!

I tried rebooting or using other machine(with windows on it) and this worked, so it's not network related. But after a few days it started not working again... So I upgraded to the Precise Pangolin hoping this behavior would go away. It didn't! After a few days I get the same behavior as in 11.10.

What am I supposed to do? Reboot every other day?

I didn't have this problem with neither 10.10 or 11.04.

I found the Realtek RTL8168/8111E issue with the r8169 driver but this is not exactly the same card so probably trying r8168 won't help.

Ethernet controller: Realtek Semiconductor Co., Ltd. RTL8101E/RTL8102E PCI Express Fast Ethernet controller (rev 02)
Subsystem: Toshiba America Info Systems Device ff1c
Flags: bus master, fast devsel, latency 0, IRQ 44
I/O ports at 4000 [size=256]
Memory at d0010000 (64-bit, prefetchable) [size=4K]
Memory at d0000000 (64-bit, prefetchable) [size=64K]
Capabilities: [40] Power Management version 7
Capabilities: [50] MSI: Enable+ Count=1/1 Maskable- 64bit+
Capabilities: [70] Express Endpoint, MSI 01
Capabilities: [ac] MSI-X: Enable- Count=2 Masked-
Capabilities: [cc] Vital Product Data
Capabilities: [100] Advanced Error Reporting
Capabilities: [140] Virtual Channel
Capabilities: [160] Device Serial Number 09-00-00-00-ff-ff-00-00
Kernel driver in use: r8169
Kernel modules: r8169
share|improve this question
    
Have you tried running a traceroute on google.com when this is happening? Since it's only one site, it almost sounds like some kind of DNS or caching issue that rebooting is "fixing" as a side effect of clearing out the culprit files. –  Shauna Nov 2 '12 at 20:02

1 Answer 1

Here is a relevant thread with the solution:

http://ubuntuforums.org/showthread.php?t=1964200

share|improve this answer
    
I also tried the r8101 version. No luck either. I updated to 12.10 in desperation hoping the 3.5 kernel would fix this issue. No luck either. I haven't tried r8101 driver on 3.5 yet but I don't think it will make a difference.... –  Sebastian Bugiu Aug 18 '12 at 19:33
    
I tried r8101...no difference. I keep getting previous TCP segment not captured in wireshark, if this is of any help –  Sebastian Bugiu Aug 18 '12 at 23:11
5  
@elomage Whilst this may theoretically answer the question, it would be preferable to include the essential parts of the answer here, and provide the link for reference. –  Eliah Kagan Dec 25 '12 at 18:18

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.