Ask Ubuntu is a question and answer site for Ubuntu users and developers. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I have installed JDK and JRE from this tutorial and have tried many methods of starting it up, yet my results are always the same. If any one could please help me I would be very grateful.

Exception in thread "Thread-3" java.lang.UnsatisfiedLinkError: /home/dennis/.minecraft/bin/natives/ /home/dennis/.minecraft/bin/natives/ wrong ELF class: ELFCLASS32 (Possible cause: architecture word width mismatch)
    at java.lang.ClassLoader$NativeLibrary.load(Native Method)
    at java.lang.ClassLoader.loadLibrary1(Unknown Source)
    at java.lang.ClassLoader.loadLibrary0(Unknown Source)
    at java.lang.ClassLoader.loadLibrary(Unknown Source)
    at java.lang.Runtime.load0(Unknown Source)
    at java.lang.System.load(Unknown Source)
    at org.lwjgl.Sys$
    at Method)
    at org.lwjgl.Sys.doLoadLibrary(
    at org.lwjgl.Sys.loadLibrary(
    at org.lwjgl.Sys.<clinit>(
    at net.minecraft.client.Minecraft.F(SourceFile:1853)
    at aoe.<init>(SourceFile:20)
    at net.minecraft.client.Minecraft.<init>(SourceFile:77)
    at anv.<init>(SourceFile:36)
    at net.minecraft.client.MinecraftApplet.init(SourceFile:36)
    at net.minecraft.Launcher.replace(
    at net.minecraft.Launcher$
share|improve this question
Looks like there is some 32/64 bit mismatch. Well, I don't remember installing Oracle JRE, and the open source one works perfectly. – Oleh Prypin Aug 4 '12 at 16:57
possible duplicate of Minecraft goes black on 12.04 and EEE901 – Eliah Kagan Oct 2 '12 at 0:42
Minecraft goes black on 12.04 and EEE901 has already been closed as a duplicate of this one. – John S Gruber Oct 4 '12 at 2:37

I play minecraft and I fixed the issue by: Using oracles version of java by using the wepupd8 teams java ppa. Follow this tutorial:

Then try this in terminal

export LD_LIBRARY_PATH="/usr/lib/jvm/java-7-oracle/jre/lib/i386" 

And then:

java -jar technic-launcher-latest.jar 

If that doesnt work for you, you will have to update your jwgl files by following this tutorial I wrote (included references at bottom if you would rather use them):

share|improve this answer
You should use export LD_LIBRARY_PATH="/usr/lib/jvm/java-7-oracle/jre/lib/amd64" for 64 bit Ubuntu (note amd64 at end) – minerz029 Sep 5 '13 at 7:26

Install OpenJDK Java 7

sudo apt-get install openjdk-7-jre

Then download the latest copy of LWJGL from here and extract it

Copy the following to ~/.minecraft/bin

  • jinput.jar
  • lwjgl.jar
  • lwjgl_util.jar

And the following to ~/.minecraft/bin/natives


Then restart Minecraft

Make sure you overwrite the files that Minecraft downloads, they are out of date.

share|improve this answer
Great, it worked for me! Thanks! :) – espectalll Dec 6 '12 at 18:09
I did not need to install OpenJDK, updating the LWJGL libs was good enough to resolve the issue on my computer. In fact, the Minecraft official website's download page recommends using the Sun/Oracle JDK. Either way, thanks for the helpful answer! – Jesse Webb Jan 8 '13 at 8:23

Instead of doing as the other post suggests, my cousin was kind enough to inform me of this option(source) found by searching specifically for my distro, but which will work with others having this same issue as well. Part of the problem was already solved by running the following from terminal.

If using java 7:

export LD_LIBRARY_PATH="/usr/lib64/jvm/java-1.7.0-openjdk-1.7.0/jre/lib/amd64/"

If not using java 7 you should be able to find the variable on google fairly easy, for java 6 for example you might try:

export LD_LIBRARY_PATH="/usr/lib64/jvm/java-1.6.0-openjdk-1.6.0/jre/lib/amd64/"

Now that should work but it didn't, so after reading the post above I decided to do as suggested and add to ~/.bashrc Adding anywhere in the file will be fine just copy and paste the above using gedit or nano:

gnomesu gedit ~/.bashrc

Now save or Ctrl + s and close gedit and then run the following to update bash:

source ~/.bashrc

Try running minecraft again and you should be set.

share|improve this answer

Install the Oracle Java client, or if your using that and having problems, try the OpenJRE.

Then, most important, you need to do this:

That got me up and running.

share|improve this answer
Welcome to Ask Ubuntu! Whilst this may theoretically answer the question, it would be preferable to include the essential parts of the answer here, and provide the link for reference. – Eliah Kagan Aug 4 '12 at 19:34

Make sure you install version 6 of OpenJDK if you use it. Minecraft has issues running with OpenJDK 7. It would be best if you install Sun Java instead.

share|improve this answer
Do you have any more detailed information, or a link to a page with information, about what kind of problems occur when trying to run Minecraft with OpenJDK 7? – Eliah Kagan Aug 4 '12 at 19:35

Try install proprietary drivers.

That helped me.

Search for additional drivers in the Unity Dash.

share|improve this answer

I got the same wrong ELF class: ELFCLASS32 error, and after upgrading LWJGL to 2.8.4 Minecraft 1.3.2 worked for me with Oracle Java 1.7.0_07 and OpenJDK 6 on Ubuntu 12.04 x86_64.

You can change the java executable with sudo update-alternatives --config java.

share|improve this answer

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.